2 issues with gm-notify in Ubuntu 10.04

Asked by Kushal Sejwal

I always used CheckGmail, but for the newly installed Ubuntu 10.04, I wanted something more intergrated to GNOME indicator applet. gm-notify is a wonderful application, loved it and using it. Thanks!!

But I found 2 issues with it:

1) Although its already there in the Startup Application, but everytime I restart my system, I have to manually click the "Google Mail" option from the indicator applet to start it. I wish it can be automatically started on startup.

2) Since gm-notify does the work of setting up our email service, I don't wish to see the "Set up Mail..." in the indicator applet. Any way to remove it?

Thanks again for this superb application.

Question information

Language:
English Edit question
Status:
Solved
For:
GMail Notifier Edit question
Assignee:
No assignee Edit question
Solved by:
nam
Solved:
Last query:
Last reply:
Revision history for this message
Best nam (nam85) said :
#1

Hey Kushal,

1) see bug #573555 (https://bugs.launchpad.net/gm-notify/+bug/573555) for a workaround.

2) you can blacklist the evolution item from the indicator panel. See https://wiki.ubuntu.com/MessagingMenu/
In short, run:
mkdir -p ~/.config/indicators/messages/applications-blacklist
cp /usr/share/indicators/messages/applications/evolution ~/.config/indicators/messages/applications-blacklist

Hope I could help you.

Revision history for this message
nam (nam85) said :
#2

I forgot to add: you may have to logout and login again for the blacklisting to take effect

Revision history for this message
Kushal Sejwal (kushalsejwal) said :
#3

Thanks nam, that solved my question.

Revision history for this message
Kushal Sejwal (kushalsejwal) said :
#4

Hey Nam,

For the first problem, the workaround worked for me as well. While for the second problem, I followed your solution but it was again showing "Set up Mail..." in the indicator applet. Since I don't use Evolution at all, I deleted the /usr/share/indicator/messages/applications/evolution file and it solved problem. I no longer see the "Set up Mail" option and now the indicator applet only contains the application which I want.

Thanks a ton for the help! I never knew problems also get sorted out here at launchpad, I used to just search the Ubuntu Forums.

Revision history for this message
nam (nam85) said :
#5

Hi Kushal,

I am not sure why the setting in ~/.config/indicators/messages/applications-blacklist did not work, thats how it is described in the ubuntu wiki.

Just as a side note: when you delete the /usr/share/indicator/messages/applications/evolution file, the "Set up Mail" option in the indicator applet will be deleted for every user. So if another user wants to use evolution, he might miss this option. ;-)

Launchpad is a great thing to get in contact with the developers of your favourite applications and with other people using that application.

Revision history for this message
Andrew (anjp) said :
#6

@Nam - worked for me too, thanks.