cannot unhide menubar

Asked by Daniele on 2009-09-27

I installed gloobus preview and the patched nautilus from tualatrix ppa
I hid the menubar by mistake and now I cannot make it show again
I didn't find an option to show it, neither in gconf. There should be a right click option in the toolbar for this, and also a way to switch the location bar between "clickable" and "writable".
It shows again only by bringing back nautilus to previous (unpatched) version

Question information

Language:
English Edit question
Status:
Solved
For:
Gloobus Edit question
Assignee:
No assignee Edit question
Solved by:
Daniele
Solved:
2009-10-01
Last query:
2009-10-01
Last reply:
2009-09-30

This question was originally filed as bug #437824.

This question was reopened

ammonkey (am-monkeyd) said : #1

there's a shortcut: alt+m to show/hide the menu bar ...by default it's hidden

ammonkey (am-monkeyd) said : #2

The normal nautilus shortcut are still here
like for location bar writable/clickable: ctrl+l..like to find a file: ctrl+f
and the differents view icons/list/etc ctrl+1 /2/3
it's a simplified nautilus from the spirit of 100 paper cuts.
perhaps we should make a note (Jordi?).

BadChoice (guitarboy000) said : #3

there's a shortcut: alt+m to show/hide the menu bar ...by default it's hidden

Daniele (rizzo-dani) said : #4

ok. sorry for reporting it as a bug but when I tried alt+m it didn't work...ctrl+1/2/3 works fine!
Tried again right now: ctrl+l brings me to the writable location bar (it comes back to clickable after pressing Enter), but if I set it in gconf to show writable by default I have to go back to gconf to view it clickable. It's not a shortcut for clickable/writable.
alt+m still doesn't work :( is there another way to show it? (like gconf or a conf file)
(btw, like the new "collapsed" layout! ;)

ammonkey (am-monkeyd) said : #5

perhaps u got alt+m already defined, check that in your gconf and/or if your windows manager already contain this shortcut.
i'll check your writeable/clickable location problem in gconf.

"(btw, like the new "collapsed" layout! ;)"
Thanx at least a good news :)

ammonkey (am-monkeyd) said : #6

concerning your writeable/clickable location problem i just tested it and it works ok (as expected)
in the gconf-editor: apps/nautilus/preferences/always_use_location_entry
check that and all the time u ll got the location entry writable
just don't forget to restart nautilus to see the changes (nautilus -q)

I've just wanted to point out what I've already written on ubuntu forums.

I really enjoy the gloobus project but submitting the so called "simplified version of nautilus" was IMHO very bad idea.
In the new version:
-> the menubar is gone
-> location bar toggle button is gone
-> view switch dropdown is gone.

Please keep in mind that not everyone expects it. I don't appreciate using keyboard shortcuts in nautilius and I like to SEE what I can do. It is simply a matter of usability. So PLEASE consider reverting your changes in this area or make the "simplified nautilus" gconf option dependent if you want to have this indeed (but keep in mind that not all people want such serious changes).

Daniele (rizzo-dani) said : #8

I agree that the simplified look should be an option, maybe in the view menu
Anyway, I checked all metacity, gconf and compiz keybindings (even tried disabling compiz) and there's no Alt+m association...
I still cannot show the menu back

Daniele (rizzo-dani) said : #9

clicked on solved by mistake, sorry!

ammonkey (am-monkeyd) said : #10

if alt+m is not working on your conf then something overide it. I suppose the window manager or gnome global shortcut

for the second one, there is several keys to check in your gconf-editor:
apps/metacity/global_keybindings
apps/metacity/window_keybindings
apps/gnome-settings-daemon/keybindings

There's another solution u can activate/deactivate in your gconf and restart nautilus to see any change
apps/nautilus/preferences/start_with_toolbar
(it seems the control of the toolbar inverted)

robersonfox (robersonfox) said : #11

This don't work for me, if start_with_toolbar is checked location bar don't show, how i could repair this bad idea?

-> I really enjoy the gloobus project but submitting the so called "simplified version of nautilus" was IMHO very bad idea.

ammonkey (am-monkeyd) said : #12

It seems there is some bugs about the behavior of the main toolbar and the gconf paremeters, i am working on it.
wait for fixes to be commited in a next ppa update. By default the menu bar will be apparent and not hidden by default (u'll can of course change this behavior in the gconf-editor).

While i am here in this section, for whose who reject the simplified nautilus, is it only the menubar hidden that disturb you and/or the fact that we merged the toolbar and the location bar in one unique bar to avoid cluttered space that nautilus provide?

Thx for your remarks nothing is fixed for the moment we opened a vote about what version to maintain in the ppa: http://gloobus.wordpress.com/2009/09/29/nautilus-or-simplified-nautilus/. Every comments are welcome. I am sure u understand we can't maintain several versions of a patch.

If u can't wait for a fixe to be commited u can go back to the original nautilus provided by Ubuntu by deactivating the ppa and then reinstall nautilus.

ammonkey (am-monkeyd) said : #13

I am back for some news.
A fix as been commited, so it's a question of hours before the next ppa update.
Now simplified nautilus has a normal behavior with gconf parameters.
So by default the menu bar (File Edit Screen ...) should appear, it depends directly on this entry on gconf:
apps/nautilus/preferences/start_with_toolbar

i added another entry in gconf for show/hide the location_button, the one next to the location bar to switch from clickable to writable: apps/nautilus/preferences/show_location_button (it should be enabled by default)

there's still the alt+m shortcut for show/hide the menu toolbar and the state of the menu bar is stored in the start_with_toolbar gconf parameter. (u see the shortcut in the menu Screen/MainBar) and like every gtk shortcut it can be editable. For that just add in your ~/.gtkrc-2.0 the line: gtk-can-change-accels = 1. Then all u have to do is select the menu where the shortcut is defined and then press a new combination of keys (be careful with that).

I hope there's no others ugly bugs around, and hope u can enjoy this version of nautilus with this new fixe.
The vote for a Nautilus or a Simplified Nautilus is still open and the winner will be in the ppa next week.

Thanx for reporting bugs and for your time.

Daniele (rizzo-dani) said : #14

I confirm that the menu is finally back!
as for now alt+m opens the Edit menu, iin italian it's "Modifica", so the "M" is the shortcut, maybe this is preventing the association for hide/unhide)

ammonkey (am-monkeyd) said : #15

Thx for your feedback the simplified nautilus version inspired by 100 papercuts is now fully implemented and functional.
You can modify your accelerator (read my previous post)
You can edit the icons in your bar by editing /usr/share/nautilus/ui/nautilus-navigation-window-ui.xml (they are in the end of the file) and comment the button u don't want like they are often duplicate in nautilus:

location button are in my opinion useless like u can already find them in the sidebar. Stop button is only usefull for network drive etc. It's up to you i just give a way to customize even more your nautilus.

 <!-- <toolitem name="Stop" action="Stop"/> -->
    <!-- <toolitem name="Reload" action="Reload"/> -->
    <!--<separator/>
 <toolitem name="Home" action="Home"/>
 <toolitem name="Computer" action="Go to Computer"/>
 <separator/>
    <toolitem name="Search" action="Search"/>-->

Regards

qweru (qweru) said : #16

the shortcut alt+m didn't worked for me but after closing sidebar with f9 it worked. enabling the sidebar seems to brake the shortcut. hope this helps

ammonkey (am-monkeyd) said : #17

"the shortcut alt+m didn't worked for me but after closing sidebar with f9 it worked. enabling the sidebar seems to brake the shortcut. hope this helps"

Hi, have u updated your system? which langage pack do u use?
The side bar and the menu bar have 2 seperates variables to store their state so i don't see how they can be linked.
I am sure u got a shortcut key who overide the alt+m one. U can redefine your gtk accelerators (shortcut key). Just read some posts above.

Samuel Dionne-Riel (samueldr) said : #18

"the shortcut alt+m didn't worked for me but after closing sidebar with f9 it worked. enabling the sidebar seems to brake the shortcut. hope this helps"

This bug is reproduced in a french language setup on archlinux with the patch applied on Nautilus 2.28.1, as per this page:
http://aur.archlinux.org/packages.php?ID=31184

On November 24th 2009.

ammonkey (am-monkeyd) said : #19

same answer as my previous message in this thread:

"I am sure u got a shortcut key who overide the alt+m one. U can redefine your gtk accelerators (shortcut key). Just read some posts above."