crash on update from icehouse

Asked by thomas on 2014-10-28

Hi, I have issue when i try to update glance from icehouse to juno
When I start glance-api and glance-registry i have this trace:
https://gist.github.com/ttwthomas/e30b254cc700268f997d

Question information

Language:
English Edit question
Status:
Solved
For:
Glance Edit question
Assignee:
No assignee Edit question
Solved by:
Stuart McLaren
Solved:
2014-10-29
Last query:
2014-10-29
Last reply:
2014-10-29

Does it work if you remove 'osprofiler' from the pipeline?

ie in glance-api.conf find

 [paste_deploy]
 flavor = keystone+cachemanagement

then match the pipeline in /etc/glance/glance-api-paste.ini (in this case glance-api-keystone+cachemanagement):

 [pipeline:glance-api-keystone+cachemanagement]
 pipeline = versionnegotiation osprofiler authtoken context cache cachemanage rootapp

edit the pipeline to remove 'osprofiler', and retry.

Also, try, in glance-api.conf turning off profiling:

 [profiler]
 # If False fully disable profiling feature.
 enabled = True

change to

 [profiler]
 # If False fully disable profiling feature.
 enabled = False

thomas (ttwthomas) said : #3

Hi Stuart,

My glance-api.conf only have
[paste_deploy]
flavor=keystone

And the correspondig pipeline doesnt have osprofiler
[pipeline:glance-api-keystone]
pipeline = versionnegotiation authtoken context rootapp

Profiler is nowhere to be found in both files. (config files are from icehouse)

Ok, I think adding:

[profiler]
 # If False fully disable profiling feature.
 enabled = False

to your glance-api.conf might work.

thomas (ttwthomas) said : #5

Thank you it is fine now :)
What is the profiling feature ?

Hi Thomas,

Great to hear that helped.

I'd appreciate it if you could file a bug for this (it impacts upgrades).

If osprofiler is not in your pipeline it should not be needed to explicitly disable it.

(I've never used the profiler, not 100% sure what it does)

thomas (ttwthomas) said : #7

Thanks Stuart McLaren, that solved my question.