503 error while uploading image in Glance

Asked by Anna on 2013-01-29

I made auch a file

export OS_TENANT_NAME=service
export OS_USERNAME=glance
export OS_PASSWORD=password
export OS_AUTH_URL="http://192.168.100.51:5000/v2.0/"

and run it, when i try to uppload an image or use glance index, there is an 503 error, also in log file

2013-01-29 13:08:09 3068 ERROR [keystone.middleware.auth_token] HTTP connection exception: 'NoneType' object has no attribute 'encode'
2013-01-29 13:08:09 3068 CRITICAL [keystone.middleware.auth_token] Unable to obtain admin token: Unable to communicate with keystone\\

And if i wanna add image, there is again 503 error , and log file is like below

2013-01-28 20:04:58 3068 INFO [keystone.middleware.auth_token] Starting keystone auth_token middleware
2013-01-28 20:04:58 3068 INFO [keystone.middleware.auth_token] Starting keystone auth_token middleware
2013-01-28 20:04:58 3068 INFO [keystone.middleware.auth_token] Starting keystone auth_token middleware
2013-01-28 20:04:58 3068 INFO [eventlet.wsgi.server] Starting single process server
2013-01-29 12:40:23 3068 WARNING [keystone.middleware.auth_token] Unable to find authentication token in headers: {'SCRIPT_NAME': '', 'HTTP_TRANSFER_ENCODING': 'chunked', 'REQUEST_METHOD': 'POST', 'PATH_INFO': '/v1/images', 'SERVER_PROTOCOL': 'HTTP/1.0', 'HTTP_X_IMAGE_META_MIN_RAM': '0', 'eventlet.posthooks': [], 'SERVER_NAME': '127.0.0.1', 'REMOTE_ADDR': '127.0.0.1', 'eventlet.input': <eventlet.wsgi.Input object at 0x2f54590>, 'wsgi.url_scheme': 'http', 'SERVER_PORT': '9292', 'HTTP_X_IMAGE_META_SIZE': '9761280', 'HTTP_X_IMAGE_META_PROTECTED': 'False', 'HTTP_X_IMAGE_META_IS_PUBLIC': 'True', 'wsgi.input': <eventlet.wsgi.Input object at 0x2f54590>, 'HTTP_HOST': '0.0.0.0:9292', 'wsgi.multithread': True, 'HTTP_X_IMAGE_META_MIN_DISK': '0', 'wsgi.version': (1, 0), 'GATEWAY_INTERFACE': 'CGI/1.1', 'wsgi.run_once': False, 'wsgi.errors': <open file '<stderr>', mode 'w' at 0x7ff368383270>, 'wsgi.multiprocess': False, 'CONTENT_TYPE': 'application/octet-stream', 'HTTP_X_IMAGE_META_NAME': 'My Image', 'HTTP_ACCEPT_ENCODING': 'identity'}
2013-01-29 12:40:23 3068 INFO [keystone.middleware.auth_token] Invalid user token - rejecting request
2013-01-29 12:40:23 3068 WARNING [keystone.middleware.auth_token] Unable to find authentication token in headers: {'SCRIPT_NAME': '', 'HTTP_TRANSFER_ENCODING': 'chunked', 'REQUEST_METHOD': 'POST', 'PATH_INFO': '/v1/images', 'SERVER_PROTOCOL': 'HTTP/1.0', 'HTTP_X_IMAGE_META_MIN_RAM': '0', 'eventlet.posthooks': [], 'SERVER_NAME': '127.0.0.1', 'REMOTE_ADDR': '127.0.0.1', 'eventlet.input': <eventlet.wsgi.Input object at 0x2f54d10>, 'wsgi.url_scheme': 'http', 'SERVER_PORT': '9292', 'HTTP_X_IMAGE_META_SIZE': '9761280', 'HTTP_X_IMAGE_META_PROTECTED': 'False', 'HTTP_X_IMAGE_META_IS_PUBLIC': 'True', 'wsgi.input': <eventlet.wsgi.Input object at 0x2f54d10>, 'HTTP_HOST': '0.0.0.0:9292', 'wsgi.multithread': True, 'HTTP_X_IMAGE_META_MIN_DISK': '0', 'wsgi.version': (1, 0), 'GATEWAY_INTERFACE': 'CGI/1.1', 'wsgi.run_once': False, 'wsgi.errors': <open file '<stderr>', mode 'w' at 0x7ff368383270>, 'wsgi.multiprocess': False, 'CONTENT_TYPE': 'application/octet-stream', 'HTTP_X_IMAGE_META_NAME': 'My Image', 'HTTP_ACCEPT_ENCODING': 'identity'}
2013-01-29 12:40:23 3068 INFO [keystone.middleware.auth_token] Invalid user token - rejecting request
2013-01-29 12:47:44 3068 ERROR [keystone.middleware.auth_token] HTTP connection exception: 'NoneType' object has no attribute 'encode'

Is there anyone can help me?

Question information

Language:
English Edit question
Status:
Solved
For:
Glance Edit question
Assignee:
No assignee Edit question
Solved by:
Anna
Solved:
2013-01-31
Last query:
2013-01-31
Last reply:
Iccha Sethi (iccha-sethi) said : #1

are your keystone settings for glance set correctly?

http://docs.openstack.org/developer/glance/authentication.html

Anna (jjador) said : #2

I checked my glance configuration, the problem was my keystone that i revised it,
By the way thank you for helping :)