glance-api & glance-registry respawning

Asked by ritesh nanda on 2012-04-16

hello
iam doing essex release deployment

when i restart the glance-api , glance-registry services it gives glance-api respawning too fast, stopped
                                                                                                                 glance-registry respawning too fast, stopped

iam pasting glance-api.conf----- http://pastebin.com/d6eB2fgE
glance-api-paste.ini ---http://pastebin.com/Mp9NY11X

glance-registry.conf----http://pastebin.com/14c6jkeF
glance-registry-paste.ini----http://pastebin.com/AWC6FTi5

Question information

Language:
English Edit question
Status:
Answered
For:
Glance Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-16
Last reply:
2012-04-17
Eoghan Glynn (eglynn) said : #1

Hi Ritesh,

Are you launching the glance services with the --respawn option?

e.g.

  $ sudo glance-control api start --respawn

or are you starting the services directly?

The respawning too fast error is intended to catch the case where the service is bouncing (i.e. launching then failing immediately with an error).

Can you check if you can launch directly, e.g.:

  $ sudo glance-api [--config-file /path/to/api/config/file]

Also can you check the api and resistry log files for errors?

ritesh nanda (riteshnanda09) said : #2

Hello Eoghan,

No iam not launching with respawn option, yes the service is bouncing
n regarding logs , till then glance-api and registry does'nt get started there are no logs for them, only syslog shows the respawning for the both services.

Stil i will try what you are asking to launch it directly .

Hello,

I've experimented the same diagnostic in syslog.

The problem seems to be related to the daemon's log files created during previous runs.

Go to the glance log directory (usually /var/log/glance) and verify what user the log files (api.log and registry.log) belong to.

If they do not belong to glance - glance, you get troubles because glance services are launched with that user (check scripts /etc/init/glance-api.conf and /etc/init/glance-registry.conf at line that says "su su -s /bin/sh -c "exec ....).

In order to fix the problem, remove or rename the log files in /var/log/glance and let the daemons created those themselves.

After removing/renaming the log files, just restart the services.

Can you help with this problem?

Provide an answer of your own, or ask ritesh nanda for more information if necessary.

To post a message you must log in.