'RequestContext' object has no attribute 'is_image_visible'

Asked by Édouard Thuleau on 2011-09-01

Hi, I get the same error than this bug: https://bugs.launchpad.net/glance/+bug/827034
I try to use Glance with Keystone. I use example configuration files given with keystone.

glance-api.conf: http://paste.openstack.org/show/2332/
glance-registry.conf: http://paste.openstack.org/show/2333/

Why I get this error ? A workaround ?

Question information

Language:
English Edit question
Status:
Solved
For:
Glance Edit question
Assignee:
No assignee Edit question
Solved by:
Édouard Thuleau
Solved:
2011-09-02
Last query:
2011-09-02
Last reply:
2011-09-01
Kevin L. Mitchell (klmitch) said : #1

Alas, the glance-registry.conf example configuration file given with keystone has not yet been updated to reflect changes to glance. The simple fix is to take the "context_class" setting from the "[filter:context]" section and copy it into the "[filter:keystone_shim]" section.

Édouard Thuleau (ethuleau) said : #2

Ok, thanks.