Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

Asked by xifeng on 2011-07-22

mi@mi-pc:~/bin$ glance add name="ubuntu1010" is_public=true < /home/mi/workspace/openstack/ubuntu1010-UEC-localuser-image.tar.gz
Failed to add image. Got error:
400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

 Error uploading image: [Errno 1] _ssl.c:499: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

Question information

Language:
English Edit question
Status:
Solved
For:
Glance Edit question
Assignee:
No assignee Edit question
Solved by:
xifeng
Solved:
2011-07-23
Last query:
2011-07-23
Last reply:
2011-07-22
Jay Pipes (jaypipes) said : #1

Please paste your glance-api.conf settings. Thanks,
jay

xifeng (xifeng) said : #2

Okay, thank you.
I had solved it!

Hugo Kou (tonytkdk) said : #3

Dear Then , how did you resolve this issue ?
I'm facing same problem now

https://answers.launchpad.net/glance/+question/176330

In my environment , there's no any service under https.....

xifeng (xifeng) said : #4

Clear your database for glance, just delete the killed rows.

在 2011-10-27,0:35,Hugo Kou <email address hidden> 写道:

> Your question #165631 on Glance changed:
> https://answers.launchpad.net/glance/+question/165631
>
> Hugo Kou posted a new comment:
> Dear Then , how did you resolve this issue ?
> I'm facing same problem now
>
> https://answers.launchpad.net/glance/+question/176330
>
> In my environment , there's no any service under https.....
>
> --
> You received this question notification because you asked the question.