ginn crashes after one-two succesfull uses (doubleclicks)

Asked by adm on 2013-12-04

lubuntu 13.10, viewsonic viewpad 10 (if it matters).

errors are (when ginn starts from a shell):

** (process:6301): WARNING **: Failed to get active application: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.ayatana.bamf was not provided by any .service files
 --ActiveApp
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 131 (XInputExtension)
  Minor opcode of failed request: 53 ()
  Value in failed request: 0x480
  Serial number of failed request: 40
  Current serial number in output stream: 41

Question information

Language:
English Edit question
Status:
Solved
For:
ginn Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen M. Webb
Solved:
2013-12-04
Last query:
2013-12-04
Last reply:
2013-12-04
Best Stephen M. Webb (bregma) said : #1

The error messages sound like the Bamf daemon has crashed: Ginn gets the active window ID by querying the Bamf daemon and uses it to talk to the X server. If the Bamf daemon has disappeared, it would explain the warning message above and the fact that Ginn worked a couple of times and then stopped. If the warning results in an invalid widow ID being sent to the X server for the XIAllowEvents request, that would explain the X Error message appearing above.

I suspect there are two issues here: (1) the Bamf demon is shuttng down and needs to be investigated, and (2) Ginn needs to handle this case more gracefully. Both should really result in bugs being reported against their respective packages.

adm (alexm-) said : #2

thank you for your answer, but it produces more questions.

i have a tablet (viewpad 10) with lubuntu 13.10 and a notebook (asus 1025b) with xubuntu 13.10, jinn is installed on both, and on the note (i.e. under xubuntu) it works fine without bamfdaemon - with the help of libbamf3-2, i suppose (it's was automatically installed by both lubuntu and xubuntu). wished.xml are the same on both, of course.

should i try to install bamfdaemon on lubuntu, or are there any other way to make jinn worked properly under lubuntu without bamfdaemon, as it does on xubuntu?

adm (alexm-) said : #3

thanks again, installation of bamfdaemon solved the lubuntu's problem with jinn, but the question about other solution is still very interesting.

adm (alexm-) said : #4

Thanks Stephen M. Webb, that solved my question.