Cursor moves randomly around the screen, cannot rotate the screen properly on Dell XT2

Asked by memetali on 2011-06-11

I have Dell XT2. The cursor is moving randomly very fast around the screen and it clicks everywhere. I had the same problem on 10.10 but after kernel updates problem had seem to be reduced but not solved. I had then Magick-Rotation installed. So when ever this situation occurred I clicked on the green icon, thus the touch function was turned off, and the problem was vanishing.

Until two days ago there was no problem about the touch screen on 11.04. Now it is impossible to work on the computer when the touch function is enabled. I still have Magick-Rotation installed, I even managed to whitelist its green icon. So when the problem occurs I disable the touch function by clicking on the green icon of magick-rotation. But it hard to reach the green icon because it is hard to capture the cursor. I can only do that with the touch-pen. Should I wait for a new kernel update? Or are there things to be done?

The other thing is, Magick-Rotation doesn't work when the screen is rotated to tablet mode and 1/3 of the screen becomes black. The black part is pretending as off-screen. Nothing can be put there or the cursor doesn't move in that area. I know that this is related with the bug https://bugs.launchpad.net/unity/+bug/776875 . May there me another solution?

Question information

Language:
English Edit question
Status:
Solved
For:
ginn Edit question
Assignee:
No assignee Edit question
Solved by:
memetali
Solved:
2011-06-22
Last query:
2011-06-22
Last reply:
Thomas Oster (thommy-oster) said : #1

Hi,
I have the same problem. My firmware version is: 4.5.2.3.5 and I get random clicks from the multitouch screen.

I'm currently installing windows 7 to upgrade the firmware to the lastest from the ntrig webpage (eventhough i dont know if its a never version because thei don't write the version number next to the download)

I will report if this makes things any better...

memetali (ma-alabora) said : #2

After some updates I have done 3 days ago, the problem seem not to be continuing. I am still not sure, I will inform as time passes. I do not know what updates where made and may have changed the situation.

Thomas Oster (thommy-oster) said : #3

Solution (Tested with Latitude XT, not XT2):
1. Upgrade firmware to the one from the Ntrig website for latest windows 7 (not the dell website) So, currently im using Firmware 4.9.15.13.7 instead of 4.5.2.3.5.
This alone doesnt remove the mouseclicks, but now the ntrig-calibrator from: https://wiki.ubuntu.com/Multitouch/Calibration/Ntrig

works. So if the mouseclicks appear, run the calb.sh as root and dont touch the screen while calib is running. Afterwards it works like a charm.

Read everything in my blog: http://ubuntuhardware.blogspot.com/