Installation

Asked by Julius Grant on 2011-05-06

I do apologize for asking the newbie question... but here goes :)

I'm new to ubuntu (Lucid) and i LOVE it. I'm trying to install ginn on my hp tx2 but I'm unsure how. I was in the readme file and it says to type in "./autogen && ./configure && make && sudo make install"

The only one that worked was "./configure" but again at the end it mentioned libutouch-geis and i have no idea how to go about getting it. Im using 0.2.4. Any help would be GREATLY appreciated.

~Julius

likwid@likwid-mp:~/ginn$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GEIS... no
configure: error: Package requirements (libutouch-geis >= 1.0.10) were not met:

No package 'libutouch-geis' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GEIS_CFLAGS
and GEIS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
likwid@likwid-mp:~/ginn$ sudo apt-get install libutouch-geis
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libutouch-geis
likwid@likwid-mp:~/ginn$

Question information

Language:
English Edit question
Status:
Answered
For:
ginn Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-06
Last reply:
2011-05-18
SimonJ (eighteenoseven) said : #1

Hi,

I ran into a little trouble myself, it seems you need the development headers.

Looking in the software centre for libutouch-geis I found libutouch-geis-dev which is the development headers and so needs installing.

Here are the other things I needed (you might need different things)

X11 "x11" needed xorg-dev
XML2 "libxml-2.0)" needed libxml2-dev
BAMF "libbamf" needed libbamf-dev

I think (but don't quote me on this one) libutouch-geis-dev came with utouch (sudo apt-get install utouch), which I don't think is actually available on lucid -- I would suggest upgrading to maverick (10.10) if you really want ginn (unless there is a version of utouch out there for lucid, I only looked in the repos at packages.ubuntu.com ).

Stephen M. Webb (bregma) said : #2

The uTouch stack has not been backported to Lucid. Whle it would be possible to backport most of the utouch stack, it requires embedding the utouch-grail recognizer into the X11 server at this time, and the version of the X11 server on Lucid is too old. That's not to say that it can not be done, but the effort is non-trivial. There may also be important features missing from the kernel input drivers for some devices.

The source code for the entire uTouch stack is available on launchpad and is under the GPL. Binary packages are available in Ubuntu 10.10 and later and build dependencies can be determined from the existing packaging if you want to try your hand at backporting.

Thanks for that info SimonJ and Stephen!

I took your advice SimonJ and upgraded to 10.10 maverick, I followed everything listed on HOW TO: Set up the HP TX2z and Dell XT & XT2 (N-trig digitizer) in Ubuntu GUIDE, and Its still not working for me. Single touch works fine, but even after utouch and all the libs are installed that are mentioned in the guide. I type "ginn" into the terminal and it loads wishes.xml but thats it. It still remains at single finger touch operation only.. I'm not sure what i'm doing wrong but am eagerly seeking any answers. Also how would i go about adding Ginn to autostart?

Thanks in advance!!!!

~Julius

Chase Douglas (chasedouglas) said : #4

Hi Julius,

What hardware do you have? Are you sure it is multitouch capable?

Thanks!

Can you help with this problem?

Provide an answer of your own, or ask Julius Grant for more information if necessary.

To post a message you must log in.