How to get the name of a gesture?

Asked by Bernard Victor Delvaux on 2014-11-08

Hello

This may sound silly but before,I could get the name of a gesture, like it is described in the geis2.c example. But now I can get every characteristics of o gesture, except its name. I get :

"gesture name": n/a

for every gesture.
I was using this result to use multitouch in my app and it was working fine some time ago. Since maybe 1 or 2 years, I can't have multitouch working anymore.
However it seems still perfectly working in ginn.

Please how can I get the name of the gesture?

Victor

Question information

Language:
English Edit question
Status:
Solved
For:
Geis Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen M. Webb
Solved:
2014-11-09
Last query:
2014-11-09
Last reply:
2014-11-08
Best Stephen M. Webb (bregma) said : #1

The GEIS2 interface classifies gestures rather than names them. A given gesture frame may be classified more than one way, so it's necessary to use the geis_frame_is_class() call to determine how the frame is classified. The class name can be retrieved using the geis_gesture_class_name() call, and availabe classes are reported through a GEIS_EVENT_CLASS_AVAILABLE event or a callback registered through the geis_register_class_callback() call. Unfortunately, the example code does not demonstrate this. Feel free to open a bug.

Using gesture frame classification allows more complex interpretations of compound gestures, such as a drag-then-rotate action.

Ginn continues to use the GEIS1 interface, which is emulated on top of the GEIS2 interface internally by arbitrarily choosing the first gesture class associated with a frame.

Thanks for the answer Stephen.

I really miss older release of libgeis. I was proud to have multitouch input in my app and it was working very well. I can't anymore. I cannot find any doc for the GEIS1 instead. And the bug GEIS_GESTURE_ATTRIBUTE_RADIUS_DELTA is always > 0 is not yet solved in GEIS2, making the pinch gesture not usable.
And the example "rectangle mover" in libgrip, after compiling the whole library (last version 0.3.8), doesn't work at all on my Ubuntu 14.04...

I guess I have to abandon multitouch input for my app...

Victor

Thanks Stephen M. Webb, that solved my question.