version 2.1.0 : installation problem with python

Asked by Bernard Victor Delvaux on 2011-06-17

Hello

I have just installed the new 2.1.0 version; however I have sen that the 'install' step could not not complete due to an error at the "python' step.

I didn't have the problem with a normal install, but I have it now because I wanted the library installed in the /usr instead of the /usr/local directory (I typed './configure --prefix=/usr')

Here is the message I have in the terminal :

make[2]: Entering directory `/home/victor/src/utouch-geis-2.1.0/python'
test -z "/usr/bin" || /bin/mkdir -p "/usr/bin"
 /usr/bin/install -c pygeis '/usr/bin'
test -z "/usr/lib/python2.7/dist-packages" || /bin/mkdir -p "/usr/lib/python2.7/dist-packages"
 /bin/bash ../libtool --mode=install /usr/bin/install -c _geis_bindings.la '/usr/lib/python2.7/dist-packages'
libtool: install: error: cannot install `_geis_bindings.la' to a directory not ending in /usr/local/lib/python2.7/dist-packages
make[2]: *** [install-pyexecLTLIBRARIES] Error 1
make[2]: Leaving directory `/home/victor/src/utouch-geis-2.1.0/python'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/victor/src/utouch-geis-2.1.0/python'
make: *** [install-recursive] Error 1

However I can still use the API since I do not use the 'python' part; the part I want to use is working fine.

Victor

Question information

Language:
English Edit question
Status:
Solved
For:
Geis Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen M. Webb
Solved:
2011-06-17
Last query:
2011-06-17
Last reply:
2011-06-17

I installed it in /usr instead of /usr/local because in the latter case, I have the following message when I run my app :

error while loading shared libraries: libutouch-geis.so.1: cannot open shared object file: No such file or directory

V

Best Stephen M. Webb (bregma) said : #2

The first problem is cause by reconfiguring between building the software and trying to install it. I can reproduce it by unpacking the source and running "./configure && make" then "./configure --prefix=/usr && make install".

The solution is to run "make clean" after the reconfiguration and before the "make install".

The second problem is symptomatic of not having /usr/local/lib in the ld.so configuration. Check to make sure that directory is in /etc/ld.so.conf or a .conf file in /etc/ld.so.conf.d.

Thanks Stephen M. Webb, that solved my question.