Mouse pointer does not respond when libgeis is active

Asked by Bernard Victor Delvaux on 2011-04-28


I have used the Libgeis2 in my software that display the harmonics of the sound in 3D; untill now I use only 1 or 2 touch gestures and it works like a charm; but when the app is running with multitouch running, is it normal that the mouse pointer does not follow the fingers anymore when there is a a single touch? The mouse pointer still follows the mouse command, but I cannot, for example, click on a button of the Gtk GUI of the app, or just change the window focus...

I'm using a filter written like this :


and I have tried GEIS_FILTER_OP_EQ too without seeing a difference.

If it is normal, please how can i get back single or double click that works natively without geis, when the app with geis is running?

Thank you

Question information

English Edit question
Geis Edit question
No assignee Edit question
Solved by:
Bernard Victor Delvaux
Last query:
Last reply:
Chase Douglas (chasedouglas) said : #1

Hi Victor,

Any time a gesture is detected, no X interaction will occur. For example, if you listen for one finger drag on a trackpad you won't be able to move the cursor while it resides within the window you are listening to gesture events from. This is to prevent one physical interaction from firing two separate events through the system.

Thank you Chase for the answer.

Can I still have the tracking of the mouse pointer outside my App's window, when my app is running?

If yes I suppose I have to create another filter and use the GEIS_FILTER_REGION parameter from the 'GeisFilterFacility' enumeration to make the gestures apply only to my app


Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Chase Douglas (chasedouglas) said : #4

Hi Victor,

Sorry for the delay in responding!

What you wrote looks correct.


Chase Douglas (chasedouglas) said : #5


Thank you Chase