Would appreciate help getting ./configure to work in fedora

Asked by Ryan Sawhill

When I run configure (from the latest tarball) on my Fedora 16 system (with gedit installed, of course), it fails out with this:
-----------
checking for GEDIT... no
configure: error: Package requirements (
    pygobject-3.0 >= 2.90.3
    gobject-introspection-1.0 >= 1.29.17
    libpeas-1.0 >= 1.1.3
    libpeas-gtk-1.0 >= 1.1.3
    gedit >= 3.1.4
) were not met:

No package 'pygobject-3.0' found
No package 'gobject-introspection-1.0' found
No package 'libpeas-1.0' found
No package 'libpeas-gtk-1.0' found
No package 'gedit' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GEDIT_CFLAGS
and GEDIT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
-----------

I KNOW I have gedit & pygobect3 (and, unrelated, but I've already installed pocket-lint) but I'm not sure what to do with the hints configure is giving me about pkg-config. Any pointers would be greatly appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Gedit Developer Plugins Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Curtis Hovey (sinzui) said :
#2

Sorry, I did not see this question.

Revision history for this message
Curtis Hovey (sinzui) said :
#3

./configure is looking for the development packges, not the application packages. I believe you need to install the *-dev version of each listed package.

Revision history for this message
Andre Lopes F. (eusoubrasileiro) said :
#4

I am still having the same issue. The problem seems to be related to pkg-config not seen what is installed.
The dev versions were installed and not change in the error.

Would be really amazing if I have any tip.

Revision history for this message
Matej (mcepl) said :
#5

For me running ./autogen.sh with Gnome 3.8.4 ends with:

checking for xgettext... (cached) /usr/bin/xgettext
checking for python module pocketlint... not found

Unfortunately, I don't see pocketlint package on PyPI.

Do you mean https://launchpad.net/pocket-lint ?

Could you please put it to the CheeseShop?

Revision history for this message
Matej (mcepl) said :
#6

And what actually is pocket-lint? Some kind NIH-version of flake8?

Can you help with this problem?

Provide an answer of your own, or ask Ryan Sawhill for more information if necessary.

To post a message you must log in.