Gedit Developer Plugins and Debian (Lenny)

Asked by Nino on 2010-11-05

Hi, I would like to know if it is possible to install Gedit Developer Plugins on Debian (Lenny). If positive, where are the instructions? Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Gedit Developer Plugins Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-05
Last reply:
2010-11-05
Curtis Hovey (sinzui) said : #1

I assume the packages in my PPA will work, but I am uncertain which is the correct one to choose. What version of gedit (help > about) are you using.

You can build from the tarball, but it requires a lot of developer dependencies. Gedit has changed quite a bit over two years and the gedit developer plugins versions are often paired gedit versions.

Nino (ninux) said : #2

My version is 2.22.3. Debian uses old versions :(

Thanks for your attention

Curtis Hovey (sinzui) said : #3

I do not think this will work because I recall there were changes to the Gedit LanguageManager between 2.22 and the oldest version packaged. You can certainly try gedit-developer-plugins from that age.

    deb http://ppa.launchpad.net/sinzui/ppa/ubuntu jaunty main

Nino (ninux) said : #4

I added the link you gave me, but in synoptic I see this version 0.3.1-0ubuntu0, is this the old version?

I've tried to install it but I am warned that it depends on libraries newer than the ones supported by my Debian.

What about: gedit-developer-plugins-2.26.3.tar.gz?

Please, be patient: I'm not a Linux expert!

Curtis Hovey (sinzui) said : #5

On Fri, 2010-11-05 at 17:49 +0000, Nino wrote:
> What about: gedit-developer-plugins-2.26.3.tar.gz?

You will need a complete tool chain to build from tarball.

gedit-dev
gnome-common
build-essential
bzr-gtk

The README and HACKING files explain how to build. The default behaviour
is to install the plugins to your personal plugin directory, which is
the easiest and fastest way to get the four plugins.

--
__Curtis C. Hovey_________
http://launchpad.net/

Can you help with this problem?

Provide an answer of your own, or ask Nino for more information if necessary.

To post a message you must log in.