./configure doesn't work in karmic

Asked by malev on 2010-03-21

Hi Curtis!
I'm having a strange problem while using ./configure in karmic.
It doesn't find gedit. It says, I don't have it installed.
I'm posting here the output:

malev@malev-laptop:~/temp/gedit-developer-plugins-0.3.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether NLS is requested... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for intltool >= 0.35.0... 0.41.0 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.0
checking for XML::Parser... ok
checking whether to enable maintainer-specific portions of Makefiles... no
checking for python... /usr/bin/python
checking for python version... 2.6
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.6/dist-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.6/dist-packages
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GEDIT... configure: error: Package requirements (
    pygtk-2.0 >= 2.14
    gedit-2.20 >= 2.26.0
) were not met:

No package 'gedit-2.20' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GEDIT_CFLAGS
and GEDIT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Question information

Language:
English Edit question
Status:
Answered
For:
Gedit Developer Plugins Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-21
Last reply:
2010-03-21
Curtis Hovey (sinzui) said : #1

You do not have developer packages installed to build the plugin. This plugin requires the python-gtk-dev and gedit-dev packages installed.

Since you are using karmic, you probably want to use the PPA that is listed on the front page: https://launchpad.net/~sinzui/+archive/ppa. YOu can get the plugin and regular updates without setting getting the development tools.

Can you help with this problem?

Provide an answer of your own, or ask malev for more information if necessary.

To post a message you must log in.