nothing happens on startup

Asked by braineatingalien on 2007-11-21

Not sure if this is a bug or not but when I open the program gdesklets it just comes up with a window that all grey and has a tile of gDesklets Shell and if I click close it will ask me to force quit it or if I just let it sit there it will disappear over time. I have a HP dv6000z laptop and I have tried reinstalling it using the synaptic package manager

Question information

Language:
English Edit question
Status:
Answered
For:
gDesklets Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-21
Last reply:
2008-06-14
Robert Pastierovic (just-me) said : #1

try running from the text console: gdesklets shell
a let us know what the output is
also what distribution u r using, desklets version (running "desklets version" command from text console)

Edmond (ekemokai-dev) said : #2

apparently deleting the hidden file ".gDesklets" in your /home/[usr] directory does the trick.

lqsohu (lqsohu) said : #3

Log messages of /home/cellon/.gdesklets/logs/gdesklets%3A0.log
/usr/lib/gdesklets/utils/ErrorFormatter.py:118: RuntimeWarning: Python C API version mismatch for module tiling: This Python has API version 1013, module til
  module = _old_imp(name, globs, locls, fromlist)
/usr/lib/gdesklets/utils/ErrorFormatter.py:118: RuntimeWarning: Python C API version mismatch for module x11: This Python has API version 1013, module x11 ha
  module = _old_imp(name, globs, locls, fromlist)

==========================================================[01/15/08-15:17:23]===
Warning: "/usr/lib/gdesklets/Controls/System" is an invalid control.

==========================================================[01/15/08-15:17:24]===
Deprecation: Sensors are deprecated since v0.30.
Please consider using controls and inline scripts.

[EXC]libORBit-2.so.0: cannot open shared object file: No such file or directory
[EXC]/usr/lib/gdesklets/utils/ErrorFormatter.py

[---] 113 # give us an absolute path.
[---] 114 #
[---] 115 _old_imp = __import__
[---] 116 def _new_imp(name, globs = {}, locls = {}, fromlist = []):
[---] 117
[ERR]> 118 module = _old_imp(name, globs, locls, fromlist)
[---] 119 # builtin modules have no "__file__" attribute, so we have to check for it
[---] 120 if (module):
[---] 121 if (hasattr(module, "__file__")):
[---] 122 module.__file__ = os.path.abspath(module.__file__)
[---] 123 return module
[---] 124 else:
Could not load sensor StarterBar

[EXC][Errno 2] No such file or directory: '/usr/lib/gdesklets/../../share/gdesklets/Sensors'
[EXC]/usr/lib/gdesklets/factory/SensorFactory.py

[---] 32 try:
[---] 33
[---] 34 for p in SENSORPATHS:
[---] 35
[---] 36 try:
[ERR]> 37 os.chdir(p)
[---] 38 except OSError:
[---] 39 continue
[---] 40
[---] 41 # reload old modules to force using the latest version; this
[---] 42 # means we can edit modules while running gDesklets
[---] 43 # TODO: clean up

==========================================================[01/15/08-15:17:25]===

Kshitij Aggarwal (funkyidol) said : #4

I tried deleting the .gdesklet folder as told, but it still doest starts for me.
using hardy heron and latest desklets version

Can you help with this problem?

Provide an answer of your own, or ask braineatingalien for more information if necessary.

To post a message you must log in.