daemon connection timeout

Asked by charlie on 2007-10-21

I have been trying to install gdesklets on a Dell Inspiron 9400 with an up to date Ubuntu 7.10
I installed it using "sudo apt-get install gdesklets" --no problems there
when attempting to run the program I get this error.

$ gdesklets
Starting gdesklets-daemon...
Connecting to daemon [### ]You need a recent version of PyGTK to run this program.

Cannot establish connection to daemon: connection timeout
The log file might help in solving the problem.

-- The log file is empty.

The python files are up to date but it looks like for some reason python cannot find many of the modules that it should.

/usr/lib/pygtk/2.0$ python pygtk-demo.py
Traceback (most recent call last):
File "pygtk-demo.py", line 18, in ?
   import gobject
ImportError: No module named gobject

the same Import Error happens with gtk & pygtk

This same problem happened in Feisty, I wound up wiping the drive and reinstalling everything, but the new install didn't help.
more interesting is that I cannot reproduce this on any other computers running ubuntu 7.10 (upgraded from 7.04) and kubuntu 7.04.

after an extensive search of the forums I decided to try posting here... any help would be greatly appreciated

-Charlie

Question information

Language:
English Edit question
Status:
Solved
For:
gDesklets Edit question
Assignee:
No assignee Edit question
Solved by:
charlie
Solved:
2007-11-04
Last query:
2007-11-04
Last reply:
2007-11-04
Qwerty Maniac (qwertymaniac) said : #1

Try this perhaps:
sudo apt-get install python-gobject

charlie (cs-321) said : #2

Thanks for your help,

I had tried that before,
What had happened was I had installed a program (ccp4i) that had changed my default version of python to 2.4...

if I ran any programs that needed 2.5 I had to preface them with python2.5. This was a pain, so I formatted the system and started over. thankfully this only took about an hour (go Ubuntu!).
I'm sure there was another way to get this to work, and if I ever find out how to do it I'll post it here

Thanks again
-Charlie

Ajmal K (k.ajmals) said : #3

ajmal@ajmal-desktop:~$ gdesklets
Starting gdesklets-daemon...
Connecting to daemon [### ]
==========================================================[10/30/10-11:14:38]===
Could not import tiling module!

Cannot establish connection to daemon: timeout!
The log file might help you solving the problem.

ajmal@ajmal-desktop:~$ sudo apt-get install python-gobject
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-gobject is already the newest version.
The following packages were automatically installed and are no longer required:
  gcj-jre gcj-4.4-jre-lib libgcj10 gcj-jre-headless gcj-4.4-base libgcj-common
  gcj-4.4-jre gcj-4.4-jre-headless libgcj10-awt
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ajmal@ajmal-desktop:~$

????

Joe Sapp (sappj) said : #4

This last comment is completely unrelated to the original, answered question. Please search the bug tracker before posting new questions. Specifically, you should look at Ubuntu bug #83922. This is a well-known Ubuntu problem.