gcc-arm-embedded

Asked by Matteo on 2018-11-16

Hello, I need to update gcc-arm-embedded from 4.9.3 to GCC 7-2017-q4.

When executing command sudo apt-get remove gcc-arm-embedded, I got the following result:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gcc-arm-embedded

I don't have any experice, does anyone can help?
Thankyou in advance

Question information

Language:
English Edit question
Status:
Answered
For:
GNU Arm Embedded Toolchain Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-16
Last reply:
2018-11-28
Jonathan Dumaresq (jdumaresq) said : #1

Hi,

This is more a question for your distro linux. Which Linux distro your are working with ?

Jonathan

Matteo (matteoscanavino) said : #2

Thankyou Jonathan for your reply.

I'm working with Ubuntu 16.04 LTS...

Matteo

Jonathan Dumaresq (jdumaresq) said : #3

Hi,

maybe you should look with this PPA ?

https://launchpad.net/~team-gcc-arm-embedded/+archive/ubuntu/ppa

Jonathan

Hi Matteo,

The package used to be named gcc-arm-none-eabi. You should thus remove that package and then install gcc-arm-embedded.

Best regards.

Can you help with this problem?

Provide an answer of your own, or ask Matteo for more information if necessary.

To post a message you must log in.