Installed on Linux but "No such file or directory" message received when using gcc

Asked by Andrew

I installed the toolchain on Linux in /usr/local as per the instructions:

* Installing executables on Linux *
Unpack the tarball to the install directory, like this:
$ cd $install_dir && tar xjf gcc-arm-none-eabi-*-yyyymmdd-linux.tar.bz2

but when attempting to use arm-none-eabi-gcc I receive a "No such file or directory" message. Is there something I am missing to complete this installation?

I've been successful in using arm-none-eabi-gcc when installing from the PPA, but I need GCC ARM Embedded 4.9 2015q3 which is not available on the PPA as far as I can tell.

Any help in sorting this out would be much appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
GNU Arm Embedded Toolchain Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew
Solved:
Last query:
Last reply:
Revision history for this message
Thomas Preud'homme (thomas-preudhomme) said :
#1

You either need to add /usr/local/gcc-arm-none-eabi-4_9-2015q3/bin to your PATH by doing:

export PATH="/usr/local/gcc-arm-none-eabi-4_9-2015q3/bin:$PATH" in your shell and your .bashrc

Or add a symbolic link from /usr/local/bin to each of the binaries in /usr/local/gcc-arm-none-eabi-4_9-2015q3/bin by doing:

cd /usr/local/bin ; for file in ../gcc-arm-none-eabi-4_9-2015q3/bin/* ; do ln -s $file ; done

Best regards.

Revision history for this message
Andrew (drufactor) said :
#2

Thanks for the reply Thomas.

I solved my problem by installing the 32 bit libraries needed with:

sudo apt-get install gcc-multilib

Apparently the "No such file or directory" message is also the message you get when trying to run a 32 bit binary on a 64 bit architecture.

Thanks!

Revision history for this message
Thomas Preud'homme (thomas-preudhomme) said :
#3

Thanks for coming back to give the resolution Andrew. That will be helpful next time someone has the same error.

Best regards.