GASP not working properly on Windows

Asked by Kasey on 2010-01-10

I was having the same problem as another user who got the glib...gerror message. So I tried running the installer as the answer to that user suggested. When I ran the installer under Vista, it would give me 3 errors during installation. "Could not create: gasp-py2.6"; "Could not set key value: Python 2.6 gasp-0.3.2"; and "C:\Python26\Removegasp.ext" -u "C:\Python26\gasp-wininst.log". After a while, I tried running the installer with admin privileges and it didn't give me those error messages.

However, now when I try to run a simple program using GASP, I get an endless sequence of console errors and efforts to open a window and the window closes. Here is the text of the script I was trying to run:

from gasp import *





I'm wondering if the problem with not getting GASP to work has to do with gtk+. I'm guessing that because the instructions for installing gasp said this:

3. Microsoft Windows

There is an .EXE installer for GASP which can be downloaded from In order for GASP to work, you must install the following packages first:


Now, PyGTK, PyCairo, and PyGObject all have installers that are .exe and ran without issue on my system. The GTK+ didn't have that kind of installer. Not knowing which gtk+ to download, I downloaded the 23mb bundle with everything and followed the readme instructions to:

Then add the bin folder to your PATH. Make sure you have no other
versions of GTK+ in PATH. Run:
    pkg-config --cflags gtk+-2.0
and verify that it prints out something reasonable. Run:
and verify that it works.

The gtk-demo works fine on my system. The path only has one reference to the bin folder of GTK+. I'm not sure what else could be preventing GASP from working. My thoughts are that I didn't properly install the GTK+.

Any ideas?

Also, I think it would be helpful to know what the first error messages are that come up on the console. However, the console only displays so much and I can never catch the scroll bar quick enough to see the first few messages.

I'm running a 64-bit version of Windows Vista on my HP laptop.

Question information

English Edit question
GASP Core Edit question
No assignee Edit question
Last query:
Last reply:
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Luke Faraone (lfaraone) said : #2

Apologies, the latest version of GASP has some implementation problems that will prevent it from working on Windows for the immediate future. I'll update the download page with information on the older version.

Can you help with this problem?

Provide an answer of your own, or ask Kasey for more information if necessary.

To post a message you must log in.