amd64?

How can i install it to amd64?
Are there any .deb or instructions/how-to available ?

Question information

Language:
English Edit question
Status:
Solved
For:
Furius ISO Mount Edit question
Assignee:
No assignee Edit question
Solved by:
marcusfurius
Solved:
2008-05-18
Last query:
2008-05-18
Last reply:
2008-05-18
marcusfurius (marcus-furius) said : #1

You can try compiling from source. Furius ISO Mount is very easy to compile.
This will make your own personal deb file.
First you need to get some prerequisites (this assumes you are using Ubuntu):

sudo apt-get install fuseiso build-essential checkinstall

Next, to compile, run the following commands:

wget http://www.marcus-furius.com/files/FuriusIsoMount/furiusisomount-0.8.0.0.tar.gz
tar xzvf furiusisomount-0.8.0.0.tar.gz
cd furiusisomount-0.8.0.0
./configure
make
sudo checkinstall

You will be asked a few questions, but you can answer the default for them all. Finally press return and Furius ISO Mount will have been compiled and installed.

Please let me know of your out come.

yes i use Ubuntu Hardy Amd64

sudo apt-get install fuseiso build-essential checkinstall <-- OK
tar xzvf furiusisomount-0.8.0.0.tar.gz <-- OK
cd furiusisomount-0.8.0.0 <-- OK
but ...

./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for pkg-config... /usr/bin/pkg-config
checking for a BSD-compatible install... /usr/bin/install -c
checking for mcs... no
configure: error: mcs Not found

not working

i then installed mono-mcs
and it configured successfully
also make and sudo checkinstall worked fine

but the application is not working :(

is seems to mounts the *.iso image successfully in my home dir but all it does is creating an empty dir inside my home dir

here is the output errors from command line
---- terminal output start ---
dimitra@igna:~$ furiusisomount
fuse: failed to open /dev/fuse: Permission denied
xdg-open: unexpected option '-u'
Try 'xdg-open --help' for more information.
---- terminal output end ---

here is also a screenshot link
http://img240.imageshack.us/img240/6127/screenshotkp7.jpg

Best marcusfurius (marcus-furius) said : #3

Okay, it would seem the problem is with fuse. Here is what you do to set permissions to use fuse:

We have to set up permissions to use fuse. This is done in two steps. First add your user to the group fuse by typing:

sudo adduser <your login username> fuse

So for example if your login-name is bgates you should type

sudo adduser bgates fuse

In most cases you will need to log out and log in again for the changes to take effect. The users group settings are only read at login.

Full details can be found here: https://help.ubuntu.com/community/FuseIso

Thanks marcusfurius, that solved my question.