getting error: Invalid parameter vc_ca_file on Vmware::Compute::Ha[0] on node node-10.domain.tld

Asked by nida on 2017-02-20

I am using Fuel 9.0 with VMware DVS plugin 3.1.0. for integration with vcenter 6.0. Even I have enabled "Bypass vCenter certificate verification" i am getting above error. what is the probable reason for this issue if anyone can identify?

Question information

Language:
English Edit question
Status:
Answered
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-20
Last reply:
2017-03-01
Romar (romar) said : #1

Opened bug 1667857 and I will post in the forum the logs and generated .yaml files

Romar (romar) said : #2

Thanks

Did upgrade - everything including the environment. Puppet still failing
in controller deployment, at 86%, with another error

[root@fuel mos_mu]# fuel2 fuel-version
api: '1'
auth_required: true
feature_groups: []
openstack_version: mitaka-9.0
release: '9.2'

On the fuel controller (astute log):
2017-02-27 15:59:05 ERROR [27033] Puppet agent took too long to
run puppet task. Mark task as failed. Node 5, task upload_cirros,
manifest /etc/puppet/modules/osnailyfacter/modular/astute/upload_cirros.pp
2017-02-27 15:14:51 ERROR [27033] Node 5, task
primary-openstack-network-agents-metadata, manifest
/etc/puppet/modules/openstack_tasks/examples/openstack-network/agents/metadata.pp,
status: stopped

On the controller (puppet log)
2017-02-27 15:15:06 NOTICE restarting services
2017-02-27 15:15:01 NOTICE Compiled catalog for node-5.domain.tld
in environment production in 3.78 seconds
2017-02-27 15:14:58 NOTICE
  (Scope(Class[Openstack_tasks::Openstack_network::Agents::Metadata]))
MODULAR: openstack_network/agents/metadata.pp
2017-02-27 15:14:51 ERR /usr/bin/puppet:8:in `<main>'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `run'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
... etc...
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/compiler.rb:244:in `block in
evaluate_relationships'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `evaluate'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:33:in `each'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `block
in evaluate'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:34:in `each'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:35:in `block
(2 levels) in evaluate'
2017-02-27 15:14:51 ERR
  /usr/lib/ruby/vendor_ruby/puppet/parser/relationship.rb:69:in
`mk_relationship'
2017-02-27 15:14:51 ERR Could not find resource
'Service[neutron-ovs-metadata]' for relationship from
'Notify[neutron.conf has been changed, going to restart neutron
metadata]' on node node-5.domain.tld

Log attached

Is this another known issue / bug? Anything missing?

Should I open another bug entry?

Thanks for advising

On 2/27/2017 5:08 AM, Oleksiy Molchanov wrote:
> Bug #1667857 status changed in Fuel for OpenStack:
>
> New => Invalid
>
> https://bugs.launchpad.net/fuel/+bug/1667857
> "Controller deployment consistently fails at 84% with "invalid vc_ca_file" error in puppet"
>
> This bug is linked to #466490.
> getting error: Invalid parameter vc_ca_file on Vmware::Compute::Ha[0] on node node-10.domain.tld
> https://answers.launchpad.net/fuel-plugin-vmware-dvs/+question/466490
>

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

nida (nida) said : #3

@romar you should check the disk space for fuel master node. It should be atleast 60 Gb. In my case all of these issues resolved when i assigned a higher disk space(earlier 45 GB)

You might need to check these files in case you haven't done yet.
https://github.com/openstack/fuel-web/commit/c7ff0d4ff5771dc881909a93b4af6018dc1ce2c7
https://review.openstack.org/#/c/370371

For me, I did check these files but no such issue was there. so most probable this error was only due to low disk space. There should be a better error notification then invalid parameter to help us reach the cause earlier.

Romar (romar) said : #4

I think I need a fresh install and do it again - the snapshot is almost
2GB and there is no obvious way to attach it, upload it or send via E-Mail

On 2/27/2017 5:08 AM, Oleksiy Molchanov wrote:
> Bug #1667857 status changed in Fuel for OpenStack:
>
> New => Invalid
>
> https://bugs.launchpad.net/fuel/+bug/1667857
> "Controller deployment consistently fails at 84% with "invalid vc_ca_file" error in puppet"
>
> This bug is linked to #466490.
> getting error: Invalid parameter vc_ca_file on Vmware::Compute::Ha[0] on node node-10.domain.tld
> https://answers.launchpad.net/fuel-plugin-vmware-dvs/+question/466490
>

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Can you help with this problem?

Provide an answer of your own, or ask nida for more information if necessary.

To post a message you must log in.