Unable to setup Fuel OS

Asked by Kareem Fazal on 2017-01-17

<I am very new to Fuel OS, please consider this as an newcomer's questions>

Downloaded the latest ISO from Mirantis website and installed the software.

During the initial setup of Fuel, entered all the necessary details. As soon as I entered details for bootstrap image (w/ proxy), and hit check button, it took me directly into sign-in page of fuel OS. Since setup exited half way through, none of my data was stored other than n/w IP for eth0 and eth1.

Notice that astute.yaml file has all default data. Re-entered the data in yaml file and saved it.

Now, I am trying to restart services. Online documents talk about, dockerctl command but the OS says it is depricated and we should use fuel-util commands. I am completely lost at this point. I am trying to bring up the box and online documentation is not helping.

I am trying to setup the OS, bring up the all the services and access Fuel UI.

Some Commands tried so far:
[root@fuel ~]# service --status-all
netconsole module not loaded
Configured devices:
lo eth0 eth1 eth2 eth3 eth4 eth5
Currently active devices:
lo eth0 eth1

[root@fuel ~]# fuel fuel-version
Can't connect to Nailgun server!
Please check connection settings in your configuration file.

[root@fuel ~]# fuel-utils -h
Usage: fuel-utils <subcommand>
Available subcommands:
  check_all - Check whether all Fuel services are up and running
  check_service <service_name> - Check whether a particular service is up and running
Available service names:
  astute
  cobbler
  keystone
  mcollective
  nailgun
  nginx
  ostf
  postgres
  rabbitmq
  rsync
  rsyslog

[root@fuel ~]# service astute restart
Redirecting to /bin/systemctl restart astute.service
Failed to restart astute.service: Unit astute.service failed to load: No such file or directory.

your help and time is greatly appreciated. Positively looking forward to work with Openstack!

Question information

Language:
English Edit question
Status:
Solved
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Solved by:
Kareem Fazal
Solved:
2017-01-20
Last query:
2017-01-20
Last reply:
Kareem Fazal (kareem.fazal) said : #2

During Setup screen, skip the steps which exits the setup and takes you directly to fuel login. I had to do it couple of times, but got it working by skipping bootstrap image and fuel setup went through fine.