Fuel Not discovering nodes after successful pxe boot

Asked by Ashley Deane on 2016-10-28

Hey all,
I'm using fuel 9 to deploy openstack.
The slave nodes pxe boot off the fuel controller and install the bootstrap image fine,
They can even ping to the internet routing throguht the fuel master .
And the syslogs are being sent to the master as well.
But the fuel master isn't discovering the nodes

Only thing that looks like an error is this

agent.log on slave node:

    2016-10-28T12:44:21.376331+00:00 err: 12:44:21.329035 #17155] ERROR -- : execution expired
    2016-10-28T12:44:21.376422+00:00 info: ["/usr/lib/ruby/1.9.1/openssl/buffering.rb:53:in `sysread'", "/usr/lib/ruby/1.9.1/openssl/buffering.rb:53:in `fill_rbuff'", "/usr/lib/ruby/1.9.1/openssl/buffering.rb:200:in `gets'", "/usr/lib/ruby/vendor_ruby/httpclient/session.rb:352:in `gets'", "/usr/lib/ruby/vendor_ruby/httpclient/session.rb:879:in `block in parse_header'", "/usr/lib/ruby/vendor_ruby/httpclient/session.rb:875:in `parse_header'", "/usr/lib/ruby/vendor_ruby/httpclient/session.rb:858:in `read_header'", "/usr/lib/ruby/vendor_ruby/httpclient/session.rb:667:in `get_header'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:1137:in `do_get_header'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:1086:in `do_get_block'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:887:in `block in do_request'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:981:in `protect_keep_alive_disconnected'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:886:in `do_request'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:774:in `request'", "/usr/lib/ruby/vendor_ruby/httpclient.rb:684:in `post'", "/usr/bin/nailgun-agent:222:in `post'", "/usr/bin/nailgun-agent:1136:in `<main>'"]

Question information

Language:
English Edit question
Status:
Solved
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Solved by:
Ashley Deane
Solved:
2016-11-07
Last query:
2016-11-07
Last reply:
Ashley Deane (deanea) said : #1

This was solved by setting the MTU size to 1498 as I'm running fuel in a vm and using linux bridge for networking

Ashley Deane (deanea) said : #2

This was solved by setting the MTU size to 1498 as I'm running fuel in a vm and using linux bridge for networking