Higher MTU on external network

Asked by pa3e1 on 2016-04-09

My application is trying to connect to an instance inside OpenStack using some packets that cannot be received by the instance due to the MTU being set at 1500. How can I set this value in fuel higher than this?
I've already got the MTU set to 9000 on the internal networks and they're working just fine.

Question information

Language:
English Edit question
Status:
Answered
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-09
Last reply:
2016-04-13
Fabrizio Soppelsa (fsoppelsa) said : #1

MOS version?
Bridged interfaces?
Network scheme (mgmt, storage, etc.)?
Neutron model?
Actual MTUs configurations on nodes?
OVS or other plugins?

What do you mean "set this value in fuel higher?"

If you're talking about Fuel itself, you may want to take a look to this document: https://docs.mirantis.com/openstack/fuel/fuel-8.0/reference-architecture.html#advanced-network-configuration-using-open-vswitch to get a quick grasp on how to setup a network model before deployment

If you're talking about setting autoadvertisement for MTUs, so that's a Neutron configuration. You just specify the MTU value in dnsmasq configuration, kill dnsmasq, and be careful that in plugin.ini there is a reference to dnsmasq.conf file.

Best regards,
Fabrizio
Mirantis Team

Can you help with this problem?

Provide an answer of your own, or ask pa3e1 for more information if necessary.

To post a message you must log in.