Setting hostname for nodes

Asked by Rob Neff on 2016-01-13

We have been setting the Fuel server name & the server hostname via a script which matched the PXE mac.

We use 2 commands:

1) Set server name in Fuel
[root@fuel ~]#psql -U nailgun -h $PGHOST -c "UPDATE nodes SET name = 'A1_ru40' where id in (select node_id from node_nic_interfaces as ni where ni.mac = '00:21:cc:61:0b:41');"

2) Set the server hostname
[root@fuel ~]# fuel node --node-id 0b:41 --hostname A1_ru40

DEPRECATION WARNING: /etc/fuel/client/config.yaml exists and will be used as the source for settings. This behavior is deprecated. Please specify the path to your custom settings file in the FUELCLIENT_CUSTOM_SETTINGS environment variable.
400 Client Error: Bad Request (hostname: u'A1_ru40' does not match '^([a-zA-Z0-9]([a-zA-Z0-9\\-]{0,61}[a-zA-Z0-9])?\\.)*[a-zA-Z0-9]([a-zA-Z0-9\\-]{0,61}[a-zA-Z0-9])?$')

Question: What does this deprecation warning mean?
Is there a better way to set the Fuel master name and the server hostname?

Thanks,
Rob

Question information

Language:
English Edit question
Status:
Answered
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Last query:
2016-01-13
Last reply:
2016-01-15
woody89 (a1007881221) said : #1

u can't use '_' in the hostname, try -

Can you help with this problem?

Provide an answer of your own, or ask Rob Neff for more information if necessary.

To post a message you must log in.