Repair the file system

Asked by mario on 2015-08-24

How to repair the file system of Fuel master?

I receive the following warning: maximal mount count reached, running e2fsck is raccomanted

mounted filesystem with ordered data mode

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Fuel for OpenStack Edit question
Assignee:
No assignee Edit question
Last query:
2015-08-24
Last reply:
2015-08-25
Michal Rostecki (mrostecki) said : #1

Hi,

I would like to ask you a few questions before further investigation.

1. Which version of Fuel you are using?
2. How many mounts you have? You can check this by following command:
cat /proc/mounts | wc -l
3. Could you provide the output of "mount" command if the number of mounts is significant?
4. Which version of Docker is installed on Fuel master? You can check this by "docker version" command? Some versions of Docker have bugs regarding too much mounts.

Regards,
Michal

Michal Rostecki (mrostecki) said : #2

Hello,

Sorry, I was going in the wrong direction in my previous reply.

There is a parameter in /etc/fstab determining in which priority the filesystem should be checked. This parameter is "pass", which is the last number in every line in /etc/fstab. If it's "2", then the given filesystem should be checked after reaching "maximum mount count" number. You can check which filesystems have such a parameter by the following command:

grep "2$" /etc/fstab | awk '{ print $1; }'

Then you can check each filesystem by command:

tune2fs -l <filesystem>

In the output of this command you will see "Mount count" and "Maximum mount count" values. If max mount count is -1, that means that the filesystem wouldn't be cheched at all.

Try to find the filesystem in which the maximum mount count is grater than -1 and lower than mount count. If you will find it, please check it. Before doing this, you should stop all deamons, containers or processes that use this filesystem. You can stop all Fuel containers by:

dockerctl list | xargs -i dockerctl stop {}

If you are sure that fs is not busy, please unmount it:

umount <filesystem>

Then you can go with checking it:

e2fsck <filesystem>

If you want to dismiss future filesystem checks, please do:

tune2fs -c -1 <filesystem>

Regards,
Michal

Can you help with this problem?

Provide an answer of your own, or ask mario for more information if necessary.

To post a message you must log in.