How Install Without PPA

Asked by Drew Trott on 2016-08-26

I recently upgraded to 16.04 Xenial and now cannot use the repos to update FFS because they have not been updated to Xenial. I have downloaded and decompressed the tar.gz file from the FFS site, but I am not sure what to do with it because it does not contain configure or make files. I have found the existing location of the two binaries, FreeFileSync and RealTimeSync (they are in usr/bin), so I can copy the new binaries over them (as root/sudo). But I don't know (1) where the rest of the files go (or how to find them), or (2) what else I have to do, if anything, to make these files operate like the old ones.

(edit 20160826 to include file locations and for clarity)

Question information

Language:
English Edit question
Status:
Solved
For:
FreeFileSync Edit question
Assignee:
No assignee Edit question
Solved by:
Drew Trott
Solved:
2016-08-26
Last query:
2016-08-26
Last reply:
Drew Trott (druid-well) said : #1

Okay, I think I have found the location of the remaining files (usr/share). If I just copy the new files into the old file locations, will everything work? Naturally I'm reluctant to do this until I have answered this question ...

Drew Trott (druid-well) said : #2

I solved my problem, but had to come here to formulate the right questions. In case anybody else is looking for the same answers, here's what I did:

(1) Downloaded newest version of FreeFileSync (8.4) from their site.

(2) Decompressed the downloaded tar.gz file in my home directory. (I used Archive Manager, but the terminal commands are easily found online.)

(3) Copied the files FreeFileSync and RealTimeSync from the decompressed directory into usr/bin, using root privileges. (I used Nemo with the Open As Root extension, but again the terminal commands are easily found.)

(4) Copied the following directories and files into usr/shared (also as root): Help (Directory), Languages (Directory), ding.wav, gong.wav, harp.wav, and Resources.zip.

This seems to run fine, picking up my old configuration without a hiccup.

Victor Tagayun (victagayun) said : #3

I am getting an error when I tried to add the ppa:

Cannot add PPA: ''This PPA does not support xenial''.

I am on Linux Mint18 Cinnamon 32bit on old machine and a newbie.

I have downloaded FreeFileSync_8.4_Source.zip and extracted it.

Inside are few folders and files:

FreeFileSync
wx+
zen
LICENSE

are these the files you are referring to? How to install in 32bit machine?

kyriakos fytrakis (kakosf) said : #4

@victagayun
There is a website with all packages for Ubuntu in deb format. I didn't write it down in case there is an accusation that I am promoting the website. So you can find it with a simple search, catch the deb file and install it. If there is no problem with the administrators, or you can contact me in private, I can surely give you the link.

Victor Tagayun (victagayun) said : #5

Hello Kyriakos,

I am specifically referring to FreeFileSync. From the download site, they only have 64bit for Ubuntu, but I have an old machine in 32bit mode OS, it is Linux mint18 Cinnamon.
I am not sure how to install FreeFileSync in this machine.
You may send me email at vic dot tagayun @ yahoo dot com, sorry for troubling you.

Thanks and best regards,

Victor

Victo (victoriseup) said : #6

@Drew Trott :

Just a clarification in step 4 :
Copied the following directories and files into usr/shared ---> into usr/shared/FreeFileSync

Otherwise, the files are not recognized by application.

SirPecanGum (sirpecangum) said : #7

In Ubuntu 16.10 it fails with error:

FreeFileSync: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Shame, I used this a lot. It is such good software, why isn't it for sale in the software center? I have donated to it before.

Zenju (zenju) said : #8

> libpng12.so.0

There will be two Ubuntu releases in the foreseeable future beginning with FFS 8.6: 1. LTS 2. Latest

SirPecanGum (sirpecangum) said : #9

Thank you! I've just made a PayPal donation to encourage! I'd like to see FFS in the software center so that I can buy it.

Pascal Mons (anton+) said : #10

I am trying to compile freefilesync 8.7 in Ubuntu Xenial 16.04.1 and it looks like there is a problem with the GCC version.

g++: error: +-I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0: No such file or directory
Makefile:103: recipe for target '../Obj/FFS_GCC_Make_Release/ffs/src/algorithm.o' failed
make[2]: *** [../Obj/FFS_GCC_Make_Release/ffs/src/algorithm.o] Error 1
make[2]: *** Waiting for unfinished jobs....

I have read somewhere else that in order to build we would need wxgtk 3.1 which is not yet available in Debian.

For version 8.6 I have read this :

It seems that there is only one method call used by FreeFileSync 8.6 that is only available in wxgt 3.1.x. This method call seems to be related to the new feature "Remember configuration history scroll position".

If you want to compile FreeFileSync 8.6 with wxgtk 3.0.x, just remove the line
"globalSettings.gui.cfgFileHistFirstItemPos = m_listBoxHistory->GetTopItem();"
from the file "FreeFileSync/Source/ui/main_dlg.cpp".

Can anyone confirm ? It is insane that when releasing a new version no mention of dependency versions is made ...

Don (ds-mart0) said : #11

Hi,
My problem is, when I install the ppa, the error is
E: Unable to locate package freefilesync
What could be doing this?