Did you changed timestamp mechanisms in FreeFileSync beetwen 5.12 and 5.14

Asked by Norbert on 2013-05-06

Hello!
I use FreeFileSync for folder synchronization between my internal laptop HDD and my external USB-HDD (both with NTFS filesystem).
Let's assume a situation I changed some file on local HDD (left pane) and run FreeFileSync with my ext. HDD (right).
I press F5, got left-to-right ">" arrow. If I press F5 again I got right-to-left "<" arrow for the same file (right file is newer), but if I compare these folders by content - there are no differences.

I checked both my HDD with CHKDSK, they have no errors. I use Ubuntu 12.04.2 with all latest upgrades and FreeFileSync 5.14.
This is not filesystem problem (fuseblk, ntfs-3g) - if I copy files from terminal with 'cp --preserve=timestamp source target' they have correct timestamps.
I tried previous version of FreeFileSync (5.12-0ubuntu1~precise from your ppa), it works normally.

So my question is: did you changed timestamp mechanisms in FreeFileSync beetwen 5.12 and 5.14? It seems that problem is related to FreeFileSync, not my system configuration.

Question information

Language:
English Edit question
Status:
Solved
For:
FreeFileSync Edit question
Assignee:
No assignee Edit question
Solved by:
Zenju
Solved:
2013-05-06
Last query:
2013-05-06
Last reply:
2013-05-06
Best Zenju (zenju) said : #1

There has been a problem with copy file modification times in v5.14 which has been fixed in the current version v5.15.

Norbert (nrbrtx) said : #2

Thank you, Zenju!
I'll stay on 5.12 until release of 5.15.

Norbert (nrbrtx) said : #3

Thanks Zenju, that solved my question.

Norbert (nrbrtx) said : #4

FreeFilesync v5.15 solves the issue.
Thank you!