How to install for Debian Squeeze?

Asked by yyehwjju on 2012-10-19

Sourceforge gave me an install_instructions_linux.txt which sent me to the following site for a .deb package.
> http://launchpad.net/freefilesync

The launchpad site claims it has no download files.
> FreeFileSync does not have any download files registered with Launchpad.

I managed to get hold of the source from Sourceforge, and the Compile.txt has instructions for debian based packages which I have included below.

> Linux - Debian(Ubuntu, Kubuntu), Suse (openSuse), Arch Linux (Chakra)
> --------------------------------------------------------------
> (0.) A prebuilt package for Debian-based Linux is available at: http://launchpad.net/freefilesync
> Debian: sudo add-apt-repository ppa:freefilesync/ffs
> sudo apt-get update
> sudo apt-get install freefilesync

These instructions FAIL with
> sudo: add-apt-repository: command not found

At this point I gave up as I am a newbie and not comfortable with manually compiling from source. Woe, is me.

Question information

Language:
English Edit question
Status:
Answered
For:
FreeFileSync Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-19
Last reply:
2012-10-20
Zenju (zenju) said : #1

> Compile.txt has instructions for debian based packages which I have included below.
These are the same as shown here on Launchpad "Summary".

> These instructions FAIL with
At least one user was able to integrate the ppa into Debian 6.0 (Squeeze):
https://sourceforge.net/p/freefilesync/discussion/847543/thread/0557ef4b
http://blog.anantshri.info/howto-add-ppa-in-debian/
However this has not been tested by me.

@Damien:
> For Debian-based Linux distributions, e.g. Ubuntu, Kubuntu, you can use a precompiled .deb package found here: http://launchpad.net/freefilesync
Should I adapt the descriptions to not talk about Debian in general, but Ubuntu/Kubuntu in particular? Or is Debian "officially" supported just like Ubuntu?

Related:
Issues with Debian Testing/7.0 (Wheezy) - contain some installation steps that might work with "Squeeze".
https://bugs.launchpad.net/freefilesync/+bug/1046716

Pragmatical advice: Compile yourself. This should not be too difficult following the steps in Compile.txt. If you find some noteworthy problem, let me know and I'll add instructions to this file, to avoid this complication in the future.

Damien Lecan (dlecan) said : #2

@yyehwjju An upload request has been opened for a long time in Debian.
See http://mentors.debian.net/package/freefilesync

FFS is looking for a Debian Sponsor to allow this upload. No success until now.

@ZenJu Ubuntu FFS builds used to be compatible with Debian.
This is now wrong.
So the package is now only compatible with Ubuntu-based Linux distributions.

Can you help with this problem?

Provide an answer of your own, or ask yyehwjju for more information if necessary.

To post a message you must log in.