Disabling the system beep

Asked by Dot Wainwright

This should be simple enough: how can I disable the system beep in Flux?

I've been able to get it to do everything I want it to besides this, but the beeping's disquieting.

Question information

English Edit question
The Fluxbuntu Linux Project Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Selene ToyKeeper (toykeeper) said :

Run this command:

  xset b off

It should disable the beeps coming out of the PC speaker (not the sound card).

If you want to make the setting permanent, add it as one of your login commands. I normally do this in my ~/.Xsession file, but you may have something similar in ~/.fluxbox/startup . If not, something like this will likely work (in ~/.Xsession):

  xset b off

Then, make sure that file is executable.

  chmod +x ~/.Xsession

Next time you log in, it should take effect.

I prefer to leave the beep enabled, but make it short and either higher or lower. For example, a short, low beep:

  xset b 50 50 20

Can you help with this problem?

Provide an answer of your own, or ask Dot Wainwright for more information if necessary.

To post a message you must log in.