Fonts in tool/task bar too small too read

Asked by George Stephenson on 2010-05-01

I've had a problem reading the text in the tool bars of Firefox for some time now and cannot find a way to improve their appearance. I am the Administrator of our home PC and I've just upgraded to Lucid Lynx, hoping the problem would go away. It hasn't. The text on the web pages is perfect, but I still have to squint to read the text in the tool bars and menus. When my wife logs on to her user desktop, all the text in her Firefox is beautifully clear! We have not changed anything from default: we both have the exactly the same settings for fonts, sizes and appearance on our desktops and in Firefox. How do I change the fonts so that mine are the same as hers?

Question information

Language:
English Edit question
Status:
Solved
For:
Mozilla Firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Jan
Solved:
2010-05-10
Last query:
2010-05-10
Last reply:
2010-05-08

This question was reopened

Does that only happen in Firefox or in any other application as well?

Dear Jan-Christoph,

Thank you for your prompt reply. The problem only occurs in Firefox.
Screen fonts in all other applications are perfect. I keep a regular
backup of my home folder on a USB hard drive. I think that I am
transferring over the old settings every time I backup, upgrade then
transfer my home folder back to the PC. If you could help me to clean
up Firefox, then that would be a great help.

Thanks once again,
Regards,
George

On Sat, 2010-05-01 at 15:32 +0000, Jan-Christoph Borchardt wrote:
> Your question #109005 on Mozilla Firefox changed:
> https://answers.edge.launchpad.net/firefox/+question/109005
>
> Status: Open => Needs information
>
> Jan-Christoph Borchardt requested for more information:
> Does that only happen in Firefox or in any other application as well?
>

Hey George, I may have found a solution for you in http://forums.debian.net/viewtopic.php?f=6&t=17685

In short, go to your home directory, into the hidden folder .mozilla/firefox/[random number].default/chrome/
There should be two files, one of them is called »userChrome-example.css«. Copy it and rename that to »userChrome.css«.
Then open the copy and uncomment the lines:
{
 font-size: 20pt !important
 }

menupopup > * {
font-size: 15pt !important
}

You may adjust the font sizes to your liking.

I hope that solves the problem. :)

Thanks for the above. It still didn't work. Somehow I have 2 different [random number].default files. I went into both /chrome files and copied/changed both chrome-example files. I ran both [random numbers] files in my /mozilla/firefox/profiles.ini file and still to no avail.

According to my desktop appearance settings on the fonts tab, the rendering is set to "sub-pixel smoothing". The "details" button gives "smoothing" at "Sub pixel" and the "hinting" at "Slight". When I first used Ubuntu 8.04, "hinting" was set to "full". This was OK until I changed to 9.10 when a new monitor driver caused problems with readability at "full" hinting. Somehow my Firefox settings behave as if "hinting" is still set at "full".

Is this any help?

I'll try anything but I'm a novice when it comes to using <Terminal>.

Thanks once again.

I guess I am out of answers then. :( At least those regarding repairing your installation of Firefox.

Sub-pixel smoothing and hinting are both settings that increase the readability of the typeface by enhancements at pixel level, they have nothing to do with the overall type size. If your machine is not seriously old, both settings should be enabled to ease reading and prevent eye strain.

My only suggestion left would be to back up your personal data from Firefox (see below on how to do that) and then completely remove everything related to it by opening up a terminal and typing: sudo apt-get remove --purge firefox

Of course, you need to back up important personal data beforehand: You can do it manually (export the bookmarks so you can import them after reinstalling, remember your extensions + settings, maybe transfer passwords) but I recommend to use Mozilla’s own Weave. It is an official add-on to synchronize bookmarks, passwords, preferences, history and open tabs (everything optional).

After that, reinstall it from the Software Center.

If you have further questions on Weave, reinstalling or anything else, don’t hesitate to ask. :)

Sorry, I forgot the link to Weave: https://mozillalabs.com/weave/

Thanks for the advice. Your instructions were easy to follow. The good news is Weave is Brilliant!

....... but the bad news is it still didn't work! I have since found out that my user type was set as "custom" instead of "administrator". I have amended that glitch. Firefox still shows thin lettering in the menus and text bars/boxes.

Oh well, thanks very much for your hard work :)

No problem George, I’m happy to help you. :)

But if you still have the problem, do not mark it as solved – there might be others who know the correct solution.

My (really) last resort before installing Ubuntu fresh would be:
– remove --purge firefox again AND
– delete the hidden folder .mozilla/firefox/ from your home folder (also from trash) AND
– open up Administration → Synaptic Package Manager, search for »firefox« and completely remove everything with firefox in its name.

After that, reinstall Firefox again. I’ll keep my fingers crossed.

If you need help, just ask again. :)

I tried that and it didn't work! But I've found the culprit. The hidden ".folders" in my home folder! As a result of various updates from Hardy Heron through to Lucid Lynx, all sorts of old settings over-ride the new ones. In the end, I opened a new user account with Administrator powers and transferred only my working files, my music files and my Evolution settings. I then downgraded and deleted the old account. But now I have TWO MORE PROBLEMS.

Problem 1) Evolution now throws up the following message box:
"Unlock Login Keyring. The Password you use to login to your computer no longer matches that of your login keyring"

No matter what I enter from the last 2 years, I cannot get into Evolution.

Problem 2) On all windows and in all programs, the three control buttons are now mixed up!
 "_" kills the window instead of parks the window on the bottom panel.

These problems do not occur in my wife's user account!

:)

So you have Firefox fonts working now and instead the button and Evolution problems? I am not familiar with Evolution because I am not using it, but I’ll look if I find a solution. :)

A solution for problem 2 may be:
You can customize the order of your window controls:
http://hubpages.com/hub/Move-Window-Controls-back-to-right-in-Ubuntu-1004
In short, you can open up a terminal and copy-paste:
gconftool-2 --set /apps/metacity/general/button_layout --type string "menu:maximize,minimize,close"

For any other configuration, change the "menu:maximize,minimize,close"-part. This string will put the menu on the left (: separates left and right) and maximize, minimize and close on the right (in that order).

I haven’t heard of mixed up control buttons until now though. You might try switching the theme by System → Preferences → Appearance.

I've solved the problem of windows buttons and the irretrievably-disappearing-window act. The bottom panel was missing the "Window Selector" function which allowed windows to minimize to the bottom panel and appear on that panel. There were several other weird things happening too. I discovered that I was still transferring old hidden files to the new version of Ubuntu from previous versions on my desktop. Like all my podcasts were in my music folder and vice versa! And my email kept asking for non-existent passwords!

The Reason: My downloaded iso file of Ubuntu 10.4 was corrupted. It took over an hour to download and was obviously missing a few important files.

Answer: I downloaded another iso file after the USA had all gone to bed and therefore internet traffic reduced by 99% (My estimated figures and yes I do have Broadband). After verification of the integrity of the disc (I burnt at the slowest speed for max quality), I rebooted from that disc. In order to prevent any errors creeping in, I copied over my backup files one folder/file at a time. Anything with hidden files in it was destroyed and not copied.

In order to prevent this bug happening again, may I suggest a pop-up window appears when upgrading versions of Ubuntu:
"This upgrade will restore all your personal settings throughout the entire system to default. Write down what system fonts etc. you wish to use and re-set them after installation."

New version then overwrites everything in sight. New Version cannot read files of same name created by old version - including hidden files and folders!.

Thanks Jan-Christoph Borchardt, that solved my question.

Wow George, sorry you had so many problems! I’m glad you could fix them. :)

Normally if you want to upgrade, you can go to System → Administration → Update Manager, then press »Settings« and in the tab »Updates« (which should be open already), and under the point »Release upgrade« choose the option »Normal releases«.

If you were upgrading from Karmic (9.10) you should have seen an option for the upgrade to the next version in the Update Manager popup that also notifies you of new updates.

As far as I know, a normal upgrade done this way does not reset personal settings to default. I’m sorry that happened to you.

As for installation ISOs:
Important ISOs should always be checked for integrity via md5 (I guess you mean that by verification) and burnt to disk at the slowest speed possible. Sadly, there currently is no other option than to do the check manually.

If there is trouble with the mirrors in the future, you can always try the official torrents – high usage there will only speed things up: http://www.ubuntu.com/getubuntu/downloadmirrors#bt

If you’re having further questions or problems, don’t hesitate to ask – we sure don’t want that happening again. ;)