1.5RC91 does not compile

Asked by Jean Brunet on 2011-08-04

I am interested in your project so I donwloaded the code for 1.5 RC91 *from lp:finiancisto, last changed Aug 02). Afer creating a project in Eclipse and pointing it to the source code the software will not compile. I get an eror in the Finaincist manifest file saying (on line 16 of the file) that it cannot find a resource that matches:

android:theme="@style/Theme.GreenDroid"

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Financisto Edit question
Assignee:
No assignee Edit question
Solved by:
Jean Brunet
Solved:
2011-08-05
Last query:
2011-08-05
Last reply:
2011-08-05

I've added dependency on GreenDroid library. You have to include its sources into the project as well. They are located in /GreenDroid. Please take a look https://github.com/cyrilmottier/GreenDroid on how to do that. Thanks

Jean Brunet (watjb85) said : #2

Thwew are still 2 compile errors:

The project cannot be build until build path errors are resolved
Unbound classpath container 'JRE system library [Android 2.2 Google APIs' in project 'MainActivity'

Note: The Android 2.2 Google API jars (android.jar and maps.jar) are being shown in the Eclipse project

I'm using IntelliJ Idea, so I might messed up .project for eclipse. Just make sure that you set SDK correctly as for any other Android project, there is nothing specific to Financisto on that front other than you have to include GreenDroid source as library project.

Jean Brunet (watjb85) said : #4

Problem solved!

Here is how to solve the problem for Eclise users:

1- Open Project->Properties
2- Click on Java Build Path
3- Select the libraries tab
4- Select "JRE system library [Android 2.2..."
5- Click on the Remove button
6- Click on OK

If Greendroid has been added as a project library then the software should now compile correctly

Jean Brunet (watjb85) said : #5

Problem solved

Tyler Rick (tyler.rick) said : #6

I ran into a similar problem when I tried to get this project to build in Eclipse.

The GreenDroid project had this error:
Unbound classpath container 'JRE system library [Android 2.2 Google APIs'

And the financisto project had this error:
Unbound classpath container: 'JRE System Library [Java SE 6 (MacOS X Default)]' in project 'ru.orangesoftware.financisto.activity.MainActivity'

I removed those items using Project->Properties -> Java Build Path

I think I might have also had to add "Google APIs [Android 2.2]" to the Libraries list.

I also selected Google APIs (Platform 2.2) on the Project->Properties->Android page, just to be safe, since that appears to be what this project is targeting. (It was set to 4.0 by default...)

Finally got it to build and run in an emulator!