Ubuntu 13.4 cannot compile

Asked by Niklas

Hello Community,

I recently installed a second VM with the new Ubuntu 13.4 and Fenics via PPA. Unfortunately the JIT Compiler cannot compile and throws a runtime error:

           RuntimeError: In instant.recompile: The module did not compile with command 'make VERBOSE=1

I tried reinstalling the package, without success. Does Fenics run with 13.4 on other machines?

Question information

Language:
English Edit question
Status:
Solved
For:
FEniCS Project Edit question
Assignee:
No assignee Edit question
Solved by:
Johannes Ring
Solved:
Last query:
Last reply:
Revision history for this message
Best Johannes Ring (johannr) said :
#1

The problem seems to be in /usr/share/ufc/UFCConfig.cmake, where /usr/lib/i386-linux-gnu/libpython2.7.so is used also on 64 bit platforms. To fix the problem temporary, change line #20 from

  set(UFC_PYTHON_LIBRARIES "/usr/lib/i386-linux-gnu/libpython2.7.so")

to

  set(UFC_PYTHON_LIBRARIES "/usr/lib/x86_64-linux-gnu/libpython2.7.so")

I will look for a more permanent fix.

Revision history for this message
Niklas (ntschech) said :
#2

Thanks Johannes Ring, that solved my question.

Revision history for this message
Johannes Ring (johannr) said :
#3

There is a fix now available in the FEniCS PPA.