Dolfin-1.0.0-1 (with CGAL support) available in any PPA?

Asked by Maximilian Albert


is a dolfin Ubuntu package for version 1.0.0-1 still available from one of the PPAs? I'm aware of the archived PPA [1], but the oldest dolfin version in there is 1.0.0-2.

The reason I'm asking is that our code doesn't compile with 1.0.0-2 because it seems like some interface changes appeared in this version (in particular in the BoundaryMesh class). Now a recent Ubuntu upgrade stealthily upgraded Dolfin on some of our computers to version 1.1.0, which is even more incompatible. We're planning to update our code base to the latest Dolfin version, but this may take some time (at least a few weeks, if not longer). In order to be able to run any simulations in the meantime, we need to downgrade again to a version that is compatible with our code, but if dolfin-1.0.0-2 is the furthest we can go back then we are likely stuck.

I tried to downgrade to the dolfin package shipped with Ubuntu (which is version 1.0.0-1), but that one is compiled without CGAL support and thus throws error messages. But perhaps I missed a PPA where this version still exists? Any pointers (or other suggestions) would be much appreciated!

Many thanks,


Question information

English Edit question
FEniCS Project Edit question
No assignee Edit question
Solved by:
Maximilian Albert
Last query:
Last reply:
Revision history for this message
Johannes Ring (johannr) said :

The the following PPA has packages for DOLFIN version 1.0.0 with CGAL support:

Revision history for this message
Maximilian Albert (cilix) said :

Thanks a lot for the quick reply, Johannes!

Unfortunately, the oldest dolfin version in that PPA is also 1.0.0-2, which already has the interface changes that make it incompatible with our code. There is no PPA which has dolfin-1.0.0-1 archived somewhere?

Revision history for this message
Johannes Ring (johannr) said :

No, the DOLFIN version is actually 1.0.0-2~ppa2~precise1, which is older than 1.0.0-2. This package is the same as 1.0.0-1 only that several dependencies (like CGAL) have been enabled.

Here is the diff from 1.0.0-1:

Revision history for this message
Maximilian Albert (cilix) said :

Oh, excellent. That's good news, thanks very much!

I just tried it, and using dolfin-1.0.0-2~ppa2~precise1 did indeed work. I was certain I had tried it before, but it turned out that I must have missed downgrading some dolfin-related packages so that our code still picked up bits of a newer version (probably 1.1.0). For the record, if somebody has the same problem, I needed the following commands to downgrade:

    sudo apt-get install libdolfin1.0=1.0.0-2~ppa2~precise1
    sudo apt-get install libdolfin1.0-dev=1.0.0-2~ppa2~precise1
    sudo apt-get install dolfin-bin=1.0.0-2~ppa2~precise1
    sudo apt-get install python-dolfin=1.0.0-2~ppa2~precise1

(Of course this requires the PPA at [1] to be enabled, which can be done in a similar way as described at [2].)

Many thanks again, Johannes! This has saved me a lot of hassle.


P.S.: As a humble suggestion, would it make sense to be slightly more generous with (sub-)version numbers? I think part of my confusion stemmed from the fact that I thought 1.0.0-2~ppa2~precise1 is the same as 1.0.0-2 (but simply happens to be provided in a particular PPA), whereas you say the latter is actually newer. So perhaps next time it would be good to number it 1.0.0-3 instead, just to make sure it can't be confused?