Makefile:618: recipe for target liboils_cstore.la

Asked by AkaSchmid on 2019-04-15

Dear all.
I am running Ubuntu 18.04.2: LTS 32-Bit ubuntu-bionic
On ARMV7 Machine
OpenSRF -3.1.0
Evergreen server : Evergreen-ILS-3.3.0

After sucessfully running
make -f Open-ILS/src/extras/Makefile.install ubuntu-bionic
PATH=/openils/bin:$PATH ./configure --prefix=/openils --sysconfdir=/openils/conf

On running make , The package break.
Makefile:618: recipe for target liboils_cstore.la

make[3]: *** [liboils_cstore.la] Error 1
make[3]: Leaving directory '/home/ubuntu/Evergreen-ILS-3.3.0/Open-ILS/src/c-apps'
Makefile:911: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/ubuntu/Evergreen-ILS-3.3.0/Open-ILS/src/c-apps'
Makefile:673: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/ubuntu/Evergreen-ILS-3.3.0/Open-ILS/src'
Makefile:407: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

Any idea how.. I might solve or debung the problem

Thanks
Edwin

Question information

Language:
English Edit question
Status:
Solved
For:
Evergreen Edit question
Assignee:
No assignee Edit question
Solved by:
Ben Shum
Solved:
2019-04-15
Last query:
2019-04-15
Last reply:
2019-04-15
Best Ben Shum (bshum) said : #1

Evergreen has only been tested on Ubuntu server 64-bit. The 32-bit versions are not presently supported, and this likely caused the errors you are seeing. I would recommend you reinstall using 64-bit Ubuntu server, and then try again.

AkaSchmid (akaschmid) said : #2

Thanks Ben Shum, that solved my question.