App muestra listado de directorios (Index Of) en vez de iniciar

Asked by omar on 2014-09-29

 Hola Eugenia, antes que nada te felicito por tu excelente trabajo con
 europio, eh aprendido mucho de tus manuales y tutos, Estoy intentando
 comencar a utilizarlo realize todos los pasos que explicas en la
 documentacion pero no logro hacer que funcione. Quedo trabado en la el
 directorio y no logro hacer que se ejecute la aplicacion.

 Adjunto archivo de configuracion por si esta el error ahi
 Tengo todos los archivos que indicas user_imports.php, urls.php, .htaccess
 Tengo el Virtual Host creado direccionado a la carpeta
 /var/www/html/europiovirtual y mi carpeta de proyecto es:
 var/www/html/

archivo virtual host
<VirtualHost *:80>
 ServerAdmin webmaster@localhost
 ServerName virtualhost
 DocumentRoot /var/www/html/virtualhost
 <Directory /var/www/html/virtualhost>
 Options All
 AllowOverride All
 Require all granted
 </Directory>

 ErrorLog /var/www/html/logs/error.log
 CustomLog /var/www/html/logs/access.log combined

</VirtualHost>

Trabajando con Ubuntu 14.04
Apache 2.4.7
PHP 5.5.9
MYSQL 5.5.38
 y los archivos log no existen.

Agradezco toda su ayuda. Gracias

[Inicio edición de Eugenia Bahit]
valores relevante en config.ini (adjuntado x otra vía):
APP_DIR = /var/www/html/europio/

Según imagen mostrada en Twitter (Referirse a: https://pbs.twimg.com/media/Byt2WmcIAAAJ_lr.png) en vez de accionarse el motor de la aplicación, se muestra un listado de directorios)
[Fin edición de Eugenia Bahit]

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Europio Engine Edit question
Assignee:
No assignee Edit question
Solved by:
omar
Solved:
2014-09-29
Last query:
2014-09-29
Last reply:
Eugenia Bahit (eugeniabahit) said : #1

Omar, creo que el problema puede estar en ModRewrite o en el archivo de configuración de Apache que Ubuntu 14.04 establece por defecto. No obstante, primero es necesario aclarar bien cuáles son las rutas correctas.

Tanto la directiva DocumentRoot del VirtualHost como la ruta indicada en el tag <Directory> del mismo archivo, deben tener la misma ruta indicada en la constante APP_DIR del config.ini de la aplicación. Esta ruta debe ser la carpeta en la cual se encuentran todos los archivos.

Comprueba que tanto DocumentRoot como Directory y APP_DIR apunten a la carpeta donde se encuentra el config.ini y que ésta posea el archivo .htaccess apuntando a app_engine.php

<code>
RewriteEngine On
RewriteRule !(^static|favicon) app_engine.php
</code>

Además, comprueba que el módulo rewrite de Apache esté activado ejecutando:

sudo a2enmod rewrite

Y luego reinicia Apache. Si el error no se corrige, tendremos que ver si algo en la config. general de Apache está generando conflictos.

omar (omar-virili) said : #2

Perdon cometi un error y te pase mal el archivo del virtual host
el archivo se llama "eurovirtual"

<VirtualHost *:80>
 ServerAdmin webmaster@localhost
 ServerName europiovirtual
 DocumentRoot /var/www/html/europio
 <Directory />
 Options All
 AllowOverride All
 Require all granted
 </Directory>

 ErrorLog /var/www/html/logs/error.log
 CustomLog /var/www/html/logs/access.log combined

 # For most configuration files from conf-available/, which are
 # enabled or disabled at a global level, it is possible to
 # include a line for only one particular virtual host. For example the
 # following line enables the CGI configuration for this host only
 # after it has been globally disabled with "a2disconf".
 #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

Este es el el contenido correctos
En terminal sale
Module rewrite already enabled

Respecto al <Directory /> decis que deberia de estar de esta forma <Directory /var/www/html/europio>
Gracias.

Eugenia Bahit (eugeniabahit) said : #3

Fijate de modificar Directory de modo que te quede así:

 <Directory /var/www/html/europio>
    Options -Indexes
    AllowOverride All
 </Directory>

Una vez que reinicies Apache, volvé a probar y contá que tal funciona. En caso de producirse un error (o que quede la pantalla en blanco), mirá el log de errores ejecutando el siguiente comando y copiando la salida aquí mismo:

tail -f /var/www/html/logs/error.log

omar (omar-virili) said : #4

Excelente al parecer ya esta tomando el core ya que al ingresar al virtual host automaticamente ya direcciona a la pagina http://europiovirtual/users/user/login
aunque no me muestra nada todavia y el log tira el siguiente error:

Mon Sep 29 16:10:59.114929 2014] [:error] [pid 15858] [client 127.0.0.1:45161] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/europio/core/mvc_engine/apphandler.php on line 88

omar (omar-virili) said : #5

Excelenteeeeee que grande que sos Eugeniaaaaa geniaaa!!! ya esta funcionando el error ultimo me lo generaba el archivo config.ini el cual de tanto probar modifique y quite el valor de la constante WEB_DIR que la tenia vacia solo agregue la "/" y magicamente aparecio la pagina de login. Graciassssss por todos los minutos que dedicaste ayudarme. Saludos a programas con europio al finnnn.

Eugenia Bahit (eugeniabahit) said : #7

No había visto el mensaje #5, cayó justo cuando respondía xD
Me alegro de que se haya resuelto! Y gracias por postearlo aquí. Varias personas podrían experimentar un problema similar y ahora ya hay forma de solucionarlo :)) ¡Gracias!