After fresh install following guide gengeo not found - bashrc as supposed to

Asked by Michael Kettermann

Hey folks,

I have a little problem with gengeo on Ubuntu 20.04 after a fresh install. It installs without errors or warnings following the guide on launchpad. I then add the PYTHONPATH line to ~/.bashrc and change the path to Python3, where it is actually installed, which worked just fine for esysparticle. However, the system does not find gengeo in any way. I can run already prepared geometries without problem using mpirun esysparticle, but every try to use gengeo gets me an error, e.g.:

 NameError: name 'circMNTable2D' is not defined


 NameError: name 'Vector3' is not defined

I assume this is some python3 issue, but I fail to find a solution by myself.
Any help is very much appreciated!


Question information

English Edit question
ESyS-Particle Edit question
No assignee Edit question
Solved by:
Michael Kettermann
Last query:
Last reply:
Revision history for this message
Michael Kettermann (michaelkettermann) said :

Ok, after just a fourth try it now works. So apparently an enduser error.

Revision history for this message
Dion Weatherley (d-weatherley) said :

Hi Michael,

Glad to hear you sorted this out.

For others who may strike difficulties installing GenGeo on Ubuntu-20.04, please note that a recent "feature" of boost-python is causing some (temporary) issues for compiling and installing gengeo. Before configuring and making gengeo, you may need to create a symbolic link as follows:
sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/

I understand that this issue will be resolved in future versions of boost-python, eliminating the need to create the above symbolic link.

Also, on systems with python-3.x, gengeo will install into the following directory by default:

Consequently, you will need to set your PYTHONPATH to include:

This can be done permanently by adding the following line to the end of ~/.bashrc:
export PYTHONPATH=/usr/local/lib/python3/dist-packages:$PYTHONPATH