Lacking bonds in GenGeo with InsertGenerator3D

Asked by Piotr Klejment on 2019-12-12

Hello!

I would like to ask about generating bonds between particles in GenGeo with InsertGenerator3D.
Let's consider a case of a cylinder with particles radius 0.5.
In this case r_min and r_max is the same, and particles are arranged regularly and also regular network of bonds appears between particles.
When I assume r_max=0.5 and r_min=0.3 I obtained randomly distributed particles connected by bonds.
However, when I apply r_max=0.5 and r_min=0.4, particles are arranged properly, but there are lacking bonds between particles. Why something like that happens with network of bonds when r_min is almost the same like r_max?

Best wishes,
Piotr Klejment

Question information

Language:
English Edit question
Status:
Solved
For:
ESyS-Particle Edit question
Assignee:
No assignee Edit question
Solved by:
SteffenAbe
Solved:
2019-12-13
Last query:
2019-12-13
Last reply:
2019-12-13
Best SteffenAbe (s-abe) said : #1

This is likely an effect of the packing algorithm. The algorithm inserts the particles in two stages - it initially puts some random "seed" particles into the volume and then tries to fit additional particles between them. At a small ratio between min and max radius there are probably no additional particles fitting between the "seed" particles. Given that the seed particles don't usually touch each other, you won't get bonds.

Steffen

Piotr Klejment (glaubiger) said : #2

Thanks SteffenAbe, that solved my question.