Version 2.3.5 dump2vtk command gets no particle

Asked by Li Zhiyong on 2018-07-03

I get the latest version by apt installing, and after the results getted, when I using dump2vtk command, I got no particle information in the vtu file.
I checked the frame_vtk.cpp file, the code of reading header file in function "vector<string> get_filenames" is as follows:
"
if(version==0){
    headerfile >> dummy >> dummy >> dummy;
    headerfile >> dummystring >> dummy;
  } else if ((version==1)||(version==2) || (version==3)) {
    headerfile >> dummystring >> dummy;
    headerfile >> dummy >> dummy >> dummy;
    headerfile >> dummystring >> geo_version;
  } else {
    cerr << "unknown checkpoint version " << version << endl;
  }
"
but there is no geo_version in the header file. So, the command cannot read the result file properly.
However, I mannually set a number in the position, so the command will read the result file, but the number of particles is wrong, it is always 2.

the command I used is "dump2vtk -i xxx -o vtk_xxx_ -rot -t 0 100 1000"
I found that if I ignored the "-rot", I will get the vtu file containing particles information correctly, However there are some problems in the paraview viewing, which I do not sure if it is my wrong process.

I do not known if I describe the problems properly, If it is, please check the problems, thank you.
Best Regards.

Question information

Language:
English Edit question
Status:
Solved
For:
ESyS-Particle Edit question
Assignee:
No assignee Edit question
Solved by:
Dion Weatherley
Solved:
2018-07-04
Last query:
2018-07-04
Last reply:
2018-07-03
Best Dion Weatherley (d-weatherley) said : #2

Hi Li Zhiyong,

This sounds like a known problem with that version of ESyS-Particle, documented here:
https://bugs.launchpad.net/esys-particle/+bug/1727586

That link also contains suggestions for how to fix this problem.

Cheers,

Dion

Li Zhiyong (lizhiyong4216) said : #3

Thank you Dion.
I tried the "quick fix..." method´╝îbut some problems are still there, that is if I ignored the "-rot" I will get the right particle number and visualize it properly, if not, the particle number is always 2.
I will try to install the package with source codes.
And thank you for your time.

Best Regards.
And looking forward to a better version.

Li

Li Zhiyong (lizhiyong4216) said : #4

Thanks Dion Weatherley, that solved my question.

Dion Weatherley (d-weatherley) said : #5

Hi Li,

What you describe regarding '-rot' is expected behaviour for simulations using particleType="NRotSphere".

The '-rot' argument to dump2vtk should only be used for simulations using rotational spheres i.e. particleType="RotSphere".

By what you describe, it appears that dump2vtk is working correctly for you now.

Cheers,

Dion

Li Zhiyong (lizhiyong4216) said : #6

Sorry for that and thank you.
I should do more works about the codes.

Li