Failed to install ESyS-Particle

Asked by Bin Cheng on 2017-05-25

Hello, I tried to install the latest revision of ESyS-Particle on Unix.

I have successfully installed all the required dependencies according to the ESyS-Particle Build and Installation Notes. But when I tried to configure and install ESyS-Particle, but I got following error:

bzr branch lp:esys-particle
bzr: ERROR: Connection error; Couldn't resolve host 'xmlrpc.edge.launchpad.net'

I guess it may result from that the super computer can not connect to the Internet, so the command "bzr branch lp:esys-particle" can not work.

Will you give me any suggestions on how to complete the remaining steps to configure and install ESyS-Particle?

Best Regards,

Bin

Question information

Language:
English Edit question
Status:
Solved
For:
ESyS-Particle Edit question
Assignee:
No assignee Edit question
Solved by:
Bin Cheng
Solved:
2017-05-31
Last query:
2017-05-31
Last reply:
2017-05-26
Qi Shao (uqqshao) said : #1

Hi Bin,

Instead of using bazaar, you can download the source-code tarball from:

https://launchpad.net/esys-particle/trunk/2.3.5

If you would like to install ESyS-Particle on super computer, you may find the following link helpful:

https://answers.launchpad.net/esys-particle/+faq/1235

Please let me know if you have further questions.

Cheers,
Qi

Bin Cheng (bincheng) said : #2

Ok, I have download the source-code and began to install it. But, unfortunately, there was still some mistake when I tried to run the following command:

../ source / configure CC= mpicc CXX = mpic ++ CXXFLAGS ="-Wall -Wextra "
-- srcdir = $HOME / BUILD /esys - particle / source -- prefix = $HOME / BUILD /
esys - particle / install --with - boost = $HOME / BUILD --with - povray --
enable - vtk --with - epydoc --enable - docs

The error message is

checking for Py_Main in -lpython2.7... no
checking for Boost headers version >= 1.34.1... no
configure: error: cannot find Boost headers version >= 1.34.1

But I followed the steps in ESyS-ParticleNotes when I installed Boost, and I found the folder named boost in /BUILD/include...

Will you give me any suggestions on what my problem is?

Best Regards,

Bin

Bin Cheng (bincheng) said : #3

Ok, I have reinstalled ESyS-Particle-2.3.2 and succeed.

I wonder if there is a problem with the latest version of the software (ESyS-Particle-2.3.5).

Thanks.