Checkpointer to VTK not working for rot_compress example

Asked by George Lesica on 2013-07-12

I am trying to use the checkpointer with the rot_compress example and not having any luck. The checkpoint files are actually generated (though I am not positive that they are formatted correctly) but after the files are converted to .vtu files via dump2vtk (command issued: dump2vtk -i compress_data -o vtk_ -t 0 251 1000) there are only two particles visible in ParaView. There isn't enough data in the .vtu files themselves, either, so it isn't a ParaView problem.

Everything works like a charm for the various other example scripts given in the tutorial. I am using the latest release version (2.2 update 1). I've also included a sample of the VTK output produced, note that there clearly aren't enough particles present.

Thoughts? Thanks!

<VTKFile type="UnstructuredGrid" version="0.1">
<UnstructuredGrid>
<Piece NumberOfPoints="2" NumberOfCells="0">
<Points>
<DataArray NumberOfComponents="3" type="Float64" format="ascii">
4.20604 -1.10261 -2.58309
0 0 0
</DataArray>
</Points>
<PointData Scalars="radius">
<DataArray type="Float64" Name="radius" NumberOfComponents="1" format="ascii">
4.20604
0
</DataArray>
<DataArray type="Int32" Name="particleTag" NumberOfComponents="1" format="ascii">
0
0
</DataArray>
<DataArray type="Float64" Name="particleMass" NumberOfComponents="1" format="ascii">
0
0
</DataArray>
<DataArray type="Int32" Name="Id" NumberOfComponents="1" format="ascii">
-1
0
</DataArray>
<DataArray type="Float64" Name="velocity" NumberOfComponents="3" format="ascii">
0 -2.58309 4.20604
0 -2.58309 4.20604
</DataArray>
<DataArray type="Float64" Name="displacement" NumberOfComponents="3" format="ascii">
3.20604 -1.68774 0
-1 -0.585126 2.58309
</DataArray>
<DataArray type="Float64" Name="initial position" NumberOfComponents="3" format="ascii">
1 0 0
1 0 0
</DataArray>
<DataArray type="Int32" Name="proc_id" NumberOfComponents="1" format="ascii">
1
1
</DataArray>
</PointData>
<Cells>
<DataArray type="Int32" NumberOfComponents="1" Name="connectivity" format="ascii">
</DataArray><DataArray type="Int32" NumberOfComponents="1" Name="offsets" format="ascii">
</DataArray>
<DataArray type="UInt8" NumberOfComponents="1" Name="types" format="ascii">
</DataArray>
</Cells>
<CellData>
<DataArray type="Float64" Name="bondStrain" NumberOfComponents="1" format="ascii">
</DataArray>
<DataArray type="Int32" Name="bondTag" NumberOfComponents="1" format="ascii">
</DataArray>
</CellData>
</Piece>
</UnstructuredGrid>
</VTKFile>

Question information

Language:
English Edit question
Status:
Solved
For:
ESyS-Particle Edit question
Assignee:
No assignee Edit question
Solved by:
Dion Weatherley
Solved:
Last query:
Last reply:
Revision history for this message
Best Dion Weatherley (d-weatherley) said :
#1

Hi George,

When converting checkpoint files from simulations using RotParticle, you need to add the '-rot' argument to the dump2vtk command. This should result in correctly formatted VTK files.

Cheers,

Dion

Revision history for this message
George Lesica (oldmanstan) said :
#2

Ahhh yes. Pretty sure that's the four hundredth time I've forgotten to add that option... Thank you!

Revision history for this message
George Lesica (oldmanstan) said :
#3

Thanks Dion Weatherley, that solved my question.