dump problem

Asked by Lou Jichao

Dear all,
When I try to dump some data about the gauss points. Using the following command:
gx = Function(mydomain).getX() ##gauss points coordinates
region = r0-length(gx-ic) ##divide into two regions
nt = whereNegative(region)

But it have some problems:
DataExpanded::dump: not configured with netCDF. Please contact your installation manager.

And I have install netCDF4 in my computer. I can run the command:
Python 2.7.12 (default, Aug 22 2019, 16:36:40)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import netCDF4
>>> '
Could you give me some advice or guidance.
Thank you very much.

Question information

English Edit question
esys-escript Edit question
No assignee Edit question
Solved by:
Adam Ellery
Last query:
Last reply:
Revision history for this message
Adam Ellery (aellery) said :

Hi Lou,

It looks like scons did not locate the netCDF libraries when you compiled escript. This is simple to fix and requires installing the netcdf development package from your repository and then recompiling escript. (Note that the netcdf library packages in your repository are different to the python netCDF4 module, which you already have installed.)

I am happy to step you through this process. Which operating system are you running?

Best regards,


Revision history for this message
Lou Jichao (ljc-1) said :

Dear Adam,
Thanks for your help. My system is Ubuntu16.04.

Revision history for this message
Best Adam Ellery (aellery) said :

Hi Jichao,

It looks like Ubuntu 16.04 repository version of libnetcdf-c++4 only supports netcdf 3. Escript can write to netcdf 3 files but you will need to upgrade to a more recent version of Ubuntu if you wish to use netcdf 4.

To install escript with netcdf 3 support, you will need to run the commands

sudo apt-get install libnetcdf-c++4-dev libnetcdf-cxx-legacy-dev libnetcdf-dev
scons options_file=scons/templates/xenial_options.py netcdf=3

Revision history for this message
Lou Jichao (ljc-1) said :

Thanks Adam Ellery, that solved my question.