Configuring Epoptes in my school - DHCP WIFI LAN

Asked by Oscar Esteve

Hello.
I'd like to setup Epoptes. I'm using Ubuntu 12.04. In my school there is a Linux openSUSE server. And my students and I are using Ubuntu 12.04 LTS. We connect to the server thourg WIFI, and it's open. IP is configured by DHCP. All computers are netbooks that work standalone. (not LSDP).

I'm not sure how to configure all. By now I have installed Epoptes on my computer, and one epoptes-client in one of a student's computer. I've worked a little with iTALC, i don't know if the process is similar or not.

Thank you very much for your help,
Oscar

Question information

Language:
English Edit question
Status:
Solved
For:
Epoptes Edit question
Assignee:
No assignee Edit question
Solved by:
Oscar Esteve
Solved:
Last query:
Last reply:
Revision history for this message
Alkis Georgopoulos (alkisg) said :
#1

Hi Oscar,

Since openSUSE doesn't have epoptes packages (yet?), you basically need to:
1) Install epoptes in your laptop, and arrange to get a static IP or a static DNS name.
2) Install epoptes-client in the student PCs, set SERVER in their /etc/default/epoptes-client to point to your laptop (unless if you reserve the DNS name "server" for your laptop, where you don't need that step), and run `sudo epoptes-client -c` to transfer your public keys to them.

Also check the http://www.epoptes.org/installation page.

Revision history for this message
Oscar Esteve (oscaresteve) said :
#2

Thank you very much, Alkis.

I'd like to ask you one more question.

Is it possible not to have an static IP and define my laptop as a server using the MAC of the wifi card?? I think this is called "aliases", am i sure?

Thanks in advance.

Revision history for this message
Alkis Georgopoulos (alkisg) said :
#3

You can't use the MAC address, epoptes uses TCP/IP and doesn't (yet?) have any ARP related code.
You should also be able to use the avahi DNS name with a dynamic IP, i.e. yourlaptop.local.

Revision history for this message
Oscar Esteve (oscaresteve) said :
#4

Thank you, Alkis. First of all i will try to set a fixed IP on my laptop. If no success, secondly, I will investigate about "avahi DNS" because i don't know very much about that.

One more question: do you know any webpage where i can find a tutorial about this type of "avahi DNS"?

Thank you very much.

Revision history for this message
Alkis Georgopoulos (alkisg) said :
#5

http://avahi.org :)

You don't need to read many things though, just try to ping a client by putting ".local" after its hostname, it works out of the box.
E.g. ping oscar-laptop.local from another PC.
So you just put that in the SERVER= variable in the clients' /etc/default/epoptes-client

Revision history for this message
Oscar Esteve (oscaresteve) said :
#6

Thank you very much, Alkis. Tomorrow I will work on this. I hope I'll know to do it!

Revision history for this message
Oscar Esteve (oscaresteve) said :
#7

Alkis! It's working.

I configured my laptop using a fixed IP, and the client as the documentation says. I'd like to say thanks to all the people that works on Gofris.
.
Gofris is great, much better than iTalc. Easier and faster configuration. And works perfectly.

I love it! Thank you very much!

Revision history for this message
Alkis Georgopoulos (alkisg) said :
#8

> I'd like to say thanks to all the people that works on Gofris.
> Gofris is great...

Maybe you meant "epoptes" there? :)

You're welcome, remember that epoptes does not yet support client reconnections so if you reboot the "server" laptop, any clients that were already connected won't reconnect again.

Revision history for this message
Oscar Esteve (oscaresteve) said :
#9

Sorry!
Yes i wanted to say "Epoptes" :-)

And lots of thanks to tell me this last detail ("epoptes does not yet support client reconnections so if you reboot the "server" laptop, any clients that were already connected won't reconnect again"). So i think that i will try to have one computer as a server and have the laptops of the teachers connecting to it to solve this little trouble because we need to avoid this possibility.

Revision history for this message
stasia (stasiascani) said :
#10

You can modify code to enable the auto reconnect. put comment # on the lines that start with "exec" and add some lines as in example below
sudo nano /usr/sbin/epoptes-client

    # Connect to the server, or keep retrying until the server gets online
    # (for standalone workstations booted before the server).
    if [ -s /etc/epoptes/server.crt ] || [ "$cert_param" = "verify=0" ]; then
   # exec socat openssl-connect:$SERVER:$PORT,$cert_param,interval=60,forever EXEC:"$cmdline"
       if [ "$TYPE" = "standalone" ]; then
           while socat openssl-connect:$SERVER:$PORT,$cert_param,interval=60,forever EXEC:"$cmdline"; do
               log_begin_msg "Connection lost. Epoptes-client reconnecting to $SERVER:$PORT..."
           done
       else
           exec socat openssl-connect:$SERVER:$PORT,$cert_param,interval=60,forever EXEC:"$cmdline"
       fi
    elif [ -f /etc/epoptes/server.crt ]; then
   # exec socat tcp:$SERVER:$PORT,interval=60,forever EXEC:"$cmdline",nofork
       if [ "$TYPE" = "standalone" ]; then
           while socat tcp:$SERVER:$PORT,interval=60,forever EXEC:"$cmdline",nofork; do
               log_begin_msg "Connection lost. Epoptes-client reconnecting to $SERVER:$PORT..."
           done
       else
           exec socat tcp:$SERVER:$PORT,interval=60,forever EXEC:"$cmdline",nofork
       fi
    else
        die "
    The epoptes certificate file, /etc/epoptes/server.crt, doesn't exist.
        die "