No module named clutter

Asked by Kristopher on 2008-10-22

I'm running a Gentoo amd64 box, have all the dependencies installed including clutter-0.8.2 and pyclutter-0.8, but I get the following error when I run entertainer-content-management.py or entertainer-frontend.py:

ImportError: No module named clutter

I can run entertainer-backend.py fine.

Both clutter-0.8.2 and pyclutter-0.8 installed without error. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Entertainer Media Center Edit question
Assignee:
No assignee Edit question
Solved by:
Kristopher
Solved:
2008-10-23
Last query:
2008-10-23
Last reply:
2008-10-22
Matt Layman (mblayman) said : #1

Kristopher, I'm not sure what advice I can really offer. I'm guessing that if you go into the python interpreter (i.e. `python` from the command line), then type "import clutter", you will probably see the same message. The backend runs fine because the backend never needs to import the clutter library.

I think that if you have problems with the install of clutter and can't figure them out, you might want to drop into the clutter IRC channel and ask around. If you find an actual bug and file it with OpenHand's Bugzilla , you might even make ebassi very happy because he's not too thrilled that the python clutter binding don't really get tested by a lot of people.

If that doesn't work, maybe you can try installing clutter 0.6 instead of 0.8. Additionally, the Entertainer Devs have not done any significant testing in 0.8, so we can't even guarantee that 0.8 will provide correct behavior.

Sorry that you're struggling with 0.8. I'm sure that we may face similar struggles in the near future as we think about upgrading to the new version.

Kristopher (krstphr) said : #2

Thanks. I found a Gentoo Portage overlay for clutter (http://gpo.zugaina.org/media-libs/clutter) and installed it through the package manager.

Although it was for 0.6.4, Python is able to find clutter now.

Thanks for your help.