'cluttergst.VideoTexture' object has no attribute 'get_playbin'

Asked by Andrew Grigorev on 2010-04-05

$ entertainer
Entertainer backend starting...
Traceback (most recent call last):
  File "/usr/bin/entertainer", line 8, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/entertainerlib/client/__init__.py", line 34, in main
    client_client = Client()
  File "/usr/lib/python2.6/site-packages/entertainerlib/client/client.py", line 33, in __init__
    self.quit_client)
  File "/usr/lib/python2.6/site-packages/entertainerlib/gui/user_interface.py", line 88, in __init__
    self.config.stage_width, self.config.stage_height)
  File "/usr/lib/python2.6/site-packages/entertainerlib/client/media_player.py", line 73, in __init__
    self.playbin = self.video_texture.get_playbin()
AttributeError: 'cluttergst.VideoTexture' object has no attribute 'get_playbin'

ArchLinux

clutter 1.2.4
clutter-gst 1.0.0
pyclutter-git 20100405
pyclutter-gst-git 20100405
entertainer-bzr 406

Is that a bug, or i should try another version of some library?

Question information

Language:
English Edit question
Status:
Solved
For:
Entertainer Media Center Edit question
Assignee:
No assignee Edit question
Solved by:
Matt Layman
Solved:
2010-04-09
Last query:
2010-04-09
Last reply:
2010-04-08
Best Matt Layman (mblayman) said : #1

Andrew,

Sorry for taking so long to reply. Entertainer is currently using an older version of pycluttergst. The problem that you've run into is an API change that occurred in the library that we haven't updated to yet. I run Ubuntu and won't have a chance to update dependencies until after I upgrade to Lucid (which I can't currently do because I need a stable work environment for graduate school code assignments). Once I have the opportunity to upgrade, I intend to do some packaging work to get Entertainer's dependencies ready for the new Ubuntu release. This will probably mean making some code changes like the one you discovered to catch up to libraries that have changed that Entertainer depends on. It might be a month or so before I really have a good opportunity to do that.

-Matt

Andrew Grigorev (ei-grad) said : #2

Thanks Matt Layman, that solved my question.

Reiner (mr-squidd) said : #3

Hi,

I had this problem too, while trying to get entertainer working on ubuntu lucid with the new versions of clutter. In the end, it did work (at least the small parts I tested) with clutter-1.2.4, clutter-gst-1.0.0 and pyclutter-1.0.0 (remaining packages from lucid). I needed to replace the get_playbin on line 73 by get_pipeline. This was renamed in clutter-gst 1.0.0. Maybe this helps.

Regards,
Reiner

Matt Layman (mblayman) said : #4

Reiner, thanks for the input.

Just a follow up note. I've now made a commit to trunk so that Entertainer will work with the cluttergst 1.0 API.