Unable to mount directory

Asked by Bensin on 2008-01-24

After running encfs for the first time (and in standard mode) and after I entered the password I get the following message:

"
fuse: failed to open /dev/fuse: Permission denied
fuse failed. Common problems:
 - fuse kernel module not installed (modprobe fuse)
 - invalid options -- see usage message
"

and the source directory does not appear to be mounted to the mountpoint directory.

Question information

Language:
English Edit question
Status:
Answered
For:
EncFS Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-25
Last reply:
2008-01-25
Vaida Bogdan (vaidab) said : #1

The permissions of /dev/fuse are for root and fuse only. Add yourself to the "fuse" group.
Try:

"sudo usermod -a -G fuse your_username"

If it doesn't work try this:

"chmod a+rw /dev/fuse" (Note that this is a security risk if you aren't the only person accesing the computer)

Tell me if it worked.

Bensin (lejmer) said : #2

I tried "sudo usermod -a -G fuse your_username" and got the same error message.

When I go to Applications -> System -> Users and groups -> Manage groups and then check the properties for the "fuse" group there are two users listed: Myself and root, but only the checkbox in front of my username is checked, the checkbox in front of root is not. Should it be?

Vaida Bogdan (vaidab) said : #3

What error message did you get? The command doesn't give any error message similar to the ones in your first post...

Also try the "chmod a+rw /dev/fuse" command (if you've got only trusted users on your computer).

Bensin (lejmer) said : #4

After "sudo usermod -a -G fuse your_username" and running encfs again I got the same error message as the first time I ran encfs.

If "chmod a+rw /dev/fuse" is a security risk (in any way) I'm weary of going that way since my purpose of using encfs is to increase security.

Should root be in the fuse group?

Vaida Bogdan (vaidab) said : #5

No, it doesn't have to be in the fuse group.

My guess is fusermount is not suid, do this: "sudo chmod 4755 /usr/bin/fusermount". There is always a security risk in having files suid root but if you want to use the program you'll have to take them.

Can you help with this problem?

Provide an answer of your own, or ask Bensin for more information if necessary.

To post a message you must log in.