error install module on version 7

Asked by Knimmet on 2013-11-16

When I copy the code to "/opt/opernerp/openerp/addons" on a openerp version 7 system, and update the modules.
I got the following error message:

Client Traceback (most recent call last):
  File "/opt/openerp/server/openerp/addons/web/", line 204, in dispatch
    response["result"] = method(self, **self.params)
  File "/opt/openerp/server/openerp/addons/web/controllers/", line 1132, in call_button
    action = self._call_kw(req, model, method, args, {})
  File "/opt/openerp/server/openerp/addons/web/controllers/", line 1120, in _call_kw
    return getattr(req.session.model(model), method)(*args, **kwargs)
  File "/opt/openerp/server/openerp/addons/web/", line 42, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/opt/openerp/server/openerp/addons/web/", line 30, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/opt/openerp/server/openerp/addons/web/", line 103, in send
    raise xmlrpclib.Fault(, formatted_info)

Server Traceback (most recent call last):
  File "/opt/openerp/server/openerp/addons/web/", line 89, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/opt/openerp/server/openerp/", line 292, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server/openerp/service/", line 626, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/openerp/osv/", line 188, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/opt/openerp/server/openerp/osv/", line 131, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server/openerp/osv/", line 197, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/opt/openerp/server/openerp/osv/", line 185, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/opt/openerp/server/openerp/addons/base/module/wizard/", line 42, in update_module
    update, add = module_obj.update_list(cr, uid,)
  File "/opt/openerp/server/openerp/addons/base/module/", line 617, in update_list
  File "/opt/openerp/server/openerp/addons/web/", line 580, in load_addons
    m = __import__('openerp.addons.' + module)
  File "/opt/openerp/server/openerp/modules/", line 133, in load_module
    mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)
  File "/opt/openerp/server/openerp/addons/ea_import/", line 26, in <module>
    import configs
  File "/opt/openerp/server/openerp/addons/ea_import/configs/", line 21, in <module>
    import mysql_config
  File "/opt/openerp/server/openerp/addons/ea_import/configs/", line 22, in <module>
    import MySQLdb as mdb
ImportError: No module named MySQLdb

What do I need to do, so I can solve this error messages. I already have installed the Mysql-server package on this Ubuntu 12.04 LTS system.

 I would really try this module!.

Question information

English Edit question
Enapps OpenERP CSV Import Tool Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Knimmet (temmink) said : #1

the solution for the above error is to install the python-mysqldb module.

apt-get install python-mysqldb

Charles Chaaya (chaaya) said : #2

I have the same problem, but on Windows 7. I installed Python 2.6 and then installed paython-mysqldb. Both installed successfully, but I still have the same error. I found that the MySQLdb folder was installed under c:\python26\lib\sitepackages. I have the feeling that it should be in OpenERP folder somewhere so that ea_import can find it. If anyone can shed some light on this I would appreciate it very much.