Ubuntu 10.04 & emgd : X doesn't start

Asked by Daniel MONDON on 2011-12-22

Hello,

I'm trying to use emgd driver with ubuntu 10.04 (X version 1.7.6).
I've got on error when loading emgd driver (compiled for X v1.7.99) : stop loading because version is different (7 against 6).

The poulsbo driver runs well, but i need more graphics performances!
May i will have thems with emgd driver ?

Thanks
Daniel.

[Edit]
Xorg.0.log extract:
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
 compiled for 1.7.6, module version = 1.0.0
 ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
 compiled for 1.7.6, module version = 1.1.0
 ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "emgd"
(II) Loading /usr/lib/xorg/modules/drivers/emgd_drv.so
(II) Module emgd: vendor="Intel(R) Corporation"
 compiled for 1.7.99, module version = 1.5.1742
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 7.0
(EE) module ABI major version (7) doesn't match the server's version (6)
(II) UnloadModule: "emgd"
(II) Unloading /usr/lib/xorg/modules/drivers/emgd_drv.so
(EE) Failed to load module "emgd" (module requirement mismatch, 0)

Question information

Language:
English Edit question
Status:
Answered
For:
Intel® EMGD driver Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-05
Last reply:
2012-03-08
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Daniel MONDON (daniel-mondon) said : #2

Still have problem.
D.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Daniel MONDON (daniel-mondon) said : #4

Still have problem.
D.

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Daniel MONDON (daniel-mondon) said : #6

Still have problem.
D.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Daniel MONDON (daniel-mondon) said : #8

Still have problem
D.

eTM (juergen-mangler) said : #9

Your stuff is quite old. The line:

(EE) module ABI major version (7) doesn't match the server's version (6)

basically says that the version of the driver is compiled against a newer ABI than xorg currently provides. So you need to update xserver-xorg-* to something with ABI 7.

Maybe easier if you don't find the correct xorg version: update to oneiric, and try emgd110 testing. Now up/downgrading or fiddling with xorg for this particular combination.

Can you help with this problem?

Provide an answer of your own, or ask Daniel MONDON for more information if necessary.

To post a message you must log in.